View Issue Details

IDProjectCategoryView StatusLast Update
0003490Path[FreeCAD] Bugpublic2018-05-23 15:29
ReportermlampertAssigned Tomlampert 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version[FreeCAD] 0.18 
Target Version[FreeCAD] 0.18Fixed in Version[FreeCAD] 0.18 
Summary0003490: Post processing always insterts TC even though it hasn't changed
DescriptionNoticed that multiple `M3` and `M6` commands were in a g-code file although there was only a single TC in the job. Checking the code it seems this came in through a refactoring quite a while ago, although the intended behaviour has always been to only insert TC commands on change.
Steps To ReproduceCreate a job, one tool and two operations.
When exporting the Job through post processing and count the number of `M6` and `M3` commands (should be one).
TagsNo tags attached.

Activities

mlampert

2018-05-21 15:51

developer   ~0011270

https://github.com/FreeCAD/FreeCAD/pull/1465/commits/c0d7743662a3ba64869ee719b6691f9250d6420c

wmayer

2018-05-23 15:29

administrator   ~0011275

https://github.com/FreeCAD/FreeCAD/commit/48aa0ba3d2dc92d1b7246a0c4aba30fa1558d59e

Issue History

Date Modified Username Field Change
2018-05-21 13:35 mlampert New Issue
2018-05-21 13:35 mlampert Status new => assigned
2018-05-21 13:35 mlampert Assigned To => mlampert
2018-05-21 15:51 mlampert Note Added: 0011270
2018-05-23 15:29 wmayer Status assigned => closed
2018-05-23 15:29 wmayer Resolution open => fixed
2018-05-23 15:29 wmayer Fixed in Version => 0.18
2018-05-23 15:29 wmayer Note Added: 0011275