View Issue Details

IDProjectCategoryView StatusLast Update
0003469Part[FreeCAD] Bugpublic2018-12-24 12:46
ReporterBravehartk2Assigned Towmayer 
PriorityhighSeveritycrashReproducibilityalways
Status closedResolutionfixed 
Product Version[FreeCAD] 0.17 
Target VersionFixed in Version[FreeCAD] 0.18 
Summary0003469: FreeCAD crashes on edge selection during fillet edge operation on extruded geometry
DescriptionEvery time I try to use the edge fillet functionality on extruded geometry FreeCAD crashes without any warning.
I created the geometry from a TextStringShape(Draft mode -> S).
Steps To Reproduce[list=1]
[*] Draft Workbench
[*] Create Text String Shape
[*] Extrude Shape in Part Workbench
[*] In Part Workbench select Extrude node from tree
[*] Fillet Selected Edges from Shape tool
[*] Selected Faces / Edges
[*] Navigationstyle OpenInventor
[*] Klick to often with CTRL down
[*] Crash
[/list]
Tagsfont, Part, String

Activities

Bravehartk2

2018-05-10 13:44

reporter   ~0011242

Sorry I'm new here.
Can I edit this issue?

My reproduction description wasn't finished yet.

The steps missing are:
[list=4]
[*] In Part Workbench select Extrude node from tree
[*] Fillet Selected Edges from Shape tool
[*] Selected Faces / Edges
[*] Navigationstyle OpenInventor
[*] Klick to often with CTRL down
[*] Crash
[/list]

Screenshot from 2018-05-10 15-39-48.png (2,095,338 bytes)

Kunda1

2018-05-30 23:53

manager   ~0011318

@Bravehartk2 the way things are done here is that we ask bug reporters to first post bugs to the forum before posting here please read https://freecadweb.org/wiki/Tracker#Recommended_Workflow
Also always post you [b]Help > About FreeCAD > Copy to clipboard[/b] info when posting a bug or asking for help. Thank you.

normandc

2018-06-11 19:57

manager   ~0011408

I don't understand step 8. "Klick to often with CTRL down"? Even substituting "often" for "open" it does not make sense.

Can't reproduce a crash. IMO it will depend on the selected font.

OS: Ubuntu 18.04 LTS
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.17.13522 (Git)
Build type: None
Branch: releases/FreeCAD-0-17
Hash: 3bb5ff4e70c0c526f2d9dd69b1004155b2f527f2
Python version: 2.7.15rc1
Qt version: 4.8.7
Coin version: 4.0.0a
OCC version: 7.2.0
Locale: French/Canada (fr_CA)

Kunda1

2018-06-25 13:06

manager   ~0011470

@Bravehartk2 please follow up

Kunda1

2018-07-12 12:35

manager   ~0011521

@Bravehartk2 ping

wmayer

2018-09-25 20:50

administrator   ~0011844

When OpenInventor style is used there is a nested call of SelectionSingleton::rmvSelection() which invalidates the internal iterator and thus leads to a crash later.

wmayer

2018-09-25 20:53

administrator   ~0011845

https://github.com/FreeCAD/FreeCAD/commit/ff0cacca0ad016948f42377333644ccecb875936

Issue History

Date Modified Username Field Change
2018-05-10 13:16 Bravehartk2 New Issue
2018-05-10 13:16 Bravehartk2 Tag Attached: Part
2018-05-10 13:18 Bravehartk2 Tag Attached: String
2018-05-10 13:18 Bravehartk2 Tag Attached: font
2018-05-10 13:19 Bravehartk2 Tag Attached: Fillet Selected Edges
2018-05-10 13:44 Bravehartk2 File Added: Screenshot from 2018-05-10 15-39-48.png
2018-05-10 13:44 Bravehartk2 Note Added: 0011242
2018-05-30 23:53 Kunda1 Status new => feedback
2018-05-30 23:53 Kunda1 Note Added: 0011318
2018-06-11 19:57 normandc Note Added: 0011408
2018-06-25 13:06 Kunda1 Note Added: 0011470
2018-07-12 12:34 Kunda1 Steps to Reproduce Updated View Revisions
2018-07-12 12:35 Kunda1 Note Added: 0011521
2018-09-25 20:50 wmayer Assigned To => wmayer
2018-09-25 20:50 wmayer Status feedback => confirmed
2018-09-25 20:50 wmayer Note Added: 0011844
2018-09-25 20:53 wmayer Status confirmed => closed
2018-09-25 20:53 wmayer Resolution open => fixed
2018-09-25 20:53 wmayer Fixed in Version => 0.18
2018-09-25 20:53 wmayer Note Added: 0011845
2018-12-24 12:46 Kunda1 Tag Detached: Fillet Selected Edges