View Issue Details

IDProjectCategoryView StatusLast Update
0003461FreeCADBugpublic2018-05-08 13:29
ReportereduardosmAssigned Tosgrogan1 
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionfixed 
Platformx86_64OSLinuxOS Version4.16.4-1-MANJARO
Product Version0.17 
Target Version0.18Fixed in Version0.17 
Summary0003461: FreeCAD crashes when changing language setting
DescriptionFreeCAD crashes when changing language settings.
Steps To ReproduceWith a clean FreeCAD installation ("~/.FreeCAD" not existing):
* Open FreeCAD.
* Open the settings window.
* Change the langiage. In my case, from Spanish (system language) to English.
* Click apply or accept.
* FreeCAD crashes immediately.
* Open FreeCAD again, language setting has not been saved.
Additional InformationConsole output is attached.
FreeCAD 0.17 has been built from Arch Linux AUR package: https://aur.archlinux.org/packages/freecad

Version info:
OS: "Manjaro Linux"
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.17.5235 (Git shallow)
Build type: Release
Branch: master
Hash: cd733757bc18992ed67a7e4e2b631cc3760963ab
Python version: 2.7.14
Qt version: 4.8.7
Coin version: 3.1.3
OCC version: 7.2.0
Locale: Spanish/Spain (es_ES)
TagsNo tags attached.

Activities

eduardosm

2018-05-06 12:45

reporter  

console.txt (5,902 bytes)
FreeCAD 0.17, Libs: 0.17R5235 (Git shallow)
© Juergen Riegel, Werner Mayer, Yorik van Havre 2001-2018
  #####                 ####  ###   ####  
  #                    #      # #   #   # 
  #     ##  #### ####  #     #   #  #   # 
  ####  # # #  # #  #  #     #####  #   # 
  #     #   #### ####  #    #     # #   # 
  #     #   #    #     #    #     # #   #  ##  ##  ##
  #     #   #### ####   ### #     # ####   ##  ##  ##

Program received signal SIGSEGV, Segmentation fault.
#0  /usr/lib/libc.so.6(+0x348e0) [0x7fb54f5338e0]
#1  0x7fb5509d39c0 in QPlainTextEdit::setWordWrapMode(QTextOption::WrapMode) from /usr/lib/libQtGui.so.4+0
#2  0x7fb5521151ab in Gui::Dialog::DlgGeneralImp::saveSettings() from /usr/lib/freecad/lib/libFreeCADGui.so+0x1fb
#3  0x7fb55211a55a in Gui::Dialog::DlgPreferencesImp::applyChanges() from /usr/lib/freecad/lib/libFreeCADGui.so+0x10a
#4  0x7fb55211ae43 in Gui::Dialog::DlgPreferencesImp::qt_metacall(QMetaObject::Call, int, void**) from /usr/lib/freecad/lib/libFreeCADGui.so+0x83
#5  0x7fb54fff57b8 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) from /usr/lib/libQtCore.so.4+0x2b8
#6  0x7fb55091b690 in QDialogButtonBox::clicked(QAbstractButton*) from /usr/lib/libQtGui.so.4+0x40
#7  /usr/lib/libQtGui.so.4(+0x5da747) [0x7fb55091b747]
#8  0x7fb54fff5c9d in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) from /usr/lib/libQtCore.so.4+0x79d
#9  0x7fb550bb2c93 in QAbstractButton::clicked(bool) from /usr/lib/libQtGui.so.4+0x43
#10  /usr/lib/libQtGui.so.4(+0x5ad2b7) [0x7fb5508ee2b7]
#11  /usr/lib/libQtGui.so.4(+0x5ae7bb) [0x7fb5508ef7bb]
#12  0x7fb5508ef8e5 in QAbstractButton::mouseReleaseEvent(QMouseEvent*) from /usr/lib/libQtGui.so.4+0x75
#13  0x7fb550579478 in QWidget::event(QEvent*) from /usr/lib/libQtGui.so.4+0x3c8
#14  0x7fb5505251f4 in QApplicationPrivate::notify_helper(QObject*, QEvent*) from /usr/lib/libQtGui.so.4+0x94
#15  0x7fb55052ca02 in QApplication::notify(QObject*, QEvent*) from /usr/lib/libQtGui.so.4+0xde2
#16  0x7fb55201f478 in Gui::GUIApplication::notify(QObject*, QEvent*) from /usr/lib/freecad/lib/libFreeCADGui.so+0x88
#17  0x7fb54ffe1e9e in QCoreApplication::notifyInternal(QObject*, QEvent*) from /usr/lib/libQtCore.so.4+0x8e
#18  0x7fb55052b62d in QApplicationPrivate::sendMouseEvent(QWidget*, QMouseEvent*, QWidget*, QWidget*, QWidget**, QPointer<QWidget>&, bool) from /usr/lib/libQtGui.so.4+0x13d
#19  /usr/lib/libQtGui.so.4(+0x263d5b) [0x7fb5505a4d5b]
#20  0x7fb5505a3b29 in QApplication::x11ProcessEvent(_XEvent*) from /usr/lib/libQtGui.so.4+0x1119
#21  /usr/lib/libQtGui.so.4(+0x28b215) [0x7fb5505cc215]
#22  /usr/lib/libglib-2.0.so.0(g_main_context_dispatch+0x2e8) [0x7fb54a0aa368]
#23  /usr/lib/libglib-2.0.so.0(+0x4c5b1) [0x7fb54a0aa5b1]
#24  /usr/lib/libglib-2.0.so.0(g_main_context_iteration+0x2e) [0x7fb54a0aa63e]
#25  0x7fb5500104b8 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) from /usr/lib/libQtCore.so.4+0x78
#26  /usr/lib/libQtGui.so.4(+0x28b3a8) [0x7fb5505cc3a8]
#27  0x7fb54ffe0224 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) from /usr/lib/libQtCore.so.4+0x44
#28  0x7fb54ffe058f in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) from /usr/lib/libQtCore.so.4+0x1bf
#29  0x7fb5509f61e8 in QDialog::exec() from /usr/lib/libQtGui.so.4+0xe8
#30  0x7fb55205ae70 in StdCmdDlgPreferences::activated(int) from /usr/lib/freecad/lib/libFreeCADGui.so+0x40
#31  0x7fb552049d3b in Gui::Command::invoke(int) from /usr/lib/freecad/lib/libFreeCADGui.so+0x7b
#32  0x7fb54fff5c9d in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) from /usr/lib/libQtCore.so.4+0x79d
#33  0x7fb55051f2f3 in QAction::triggered(bool) from /usr/lib/libQtGui.so.4+0x43
#34  0x7fb55052077b in QAction::activate(QAction::ActionEvent) from /usr/lib/libQtGui.so.4+0xbb
#35  /usr/lib/libQtGui.so.4(+0x62f005) [0x7fb550970005]
#36  /usr/lib/libQtGui.so.4(+0x6339f5) [0x7fb5509749f5]
#37  0x7fb550579478 in QWidget::event(QEvent*) from /usr/lib/libQtGui.so.4+0x3c8
#38  0x7fb55097877c in QMenu::event(QEvent*) from /usr/lib/libQtGui.so.4+0x6c
#39  0x7fb5505251f4 in QApplicationPrivate::notify_helper(QObject*, QEvent*) from /usr/lib/libQtGui.so.4+0x94
#40  0x7fb55052ca02 in QApplication::notify(QObject*, QEvent*) from /usr/lib/libQtGui.so.4+0xde2
#41  0x7fb55201f478 in Gui::GUIApplication::notify(QObject*, QEvent*) from /usr/lib/freecad/lib/libFreeCADGui.so+0x88
#42  0x7fb54ffe1e9e in QCoreApplication::notifyInternal(QObject*, QEvent*) from /usr/lib/libQtCore.so.4+0x8e
#43  0x7fb55052b62d in QApplicationPrivate::sendMouseEvent(QWidget*, QMouseEvent*, QWidget*, QWidget*, QWidget**, QPointer<QWidget>&, bool) from /usr/lib/libQtGui.so.4+0x13d
#44  /usr/lib/libQtGui.so.4(+0x263b5e) [0x7fb5505a4b5e]
#45  0x7fb5505a3b29 in QApplication::x11ProcessEvent(_XEvent*) from /usr/lib/libQtGui.so.4+0x1119
#46  /usr/lib/libQtGui.so.4(+0x28b215) [0x7fb5505cc215]
#47  /usr/lib/libglib-2.0.so.0(g_main_context_dispatch+0x2e8) [0x7fb54a0aa368]
#48  /usr/lib/libglib-2.0.so.0(+0x4c5b1) [0x7fb54a0aa5b1]
#49  /usr/lib/libglib-2.0.so.0(g_main_context_iteration+0x2e) [0x7fb54a0aa63e]
#50  0x7fb5500104b8 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) from /usr/lib/libQtCore.so.4+0x78
#51  /usr/lib/libQtGui.so.4(+0x28b3a8) [0x7fb5505cc3a8]
#52  0x7fb54ffe0224 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) from /usr/lib/libQtCore.so.4+0x44
#53  0x7fb54ffe058f in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) from /usr/lib/libQtCore.so.4+0x1bf
#54  0x7fb54ffe5de0 in QCoreApplication::exec() from /usr/lib/libQtCore.so.4+0xa0
#55  0x7fb551fd21ec in Gui::Application::runApplication() from /usr/lib/freecad/lib/libFreeCADGui.so+0x147c
#56  freecad(main+0x6db) [0x558f31a0945b]
#57  /usr/lib/libc.so.6(__libc_start_main+0xea) [0x7fb54f51ff4a]
#58  freecad(_start+0x2a) [0x558f31a0a60a] 
console.txt (5,902 bytes)

Kunda1

2018-05-07 02:08

manager   ~0011234

Can confirm on
[code=text]OS: "Manjaro Linux"
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.17.5235 (Git shallow)
Build type: Release
Branch: master
Hash: cd733757bc18992ed67a7e4e2b631cc3760963ab
Python version: 2.7.14
Qt version: 4.8.7
Coin version: 3.1.3
OCC version: 7.2.0
Locale: English/UnitedStates (en_US)
[/code]

I tried to change language and got the following segfault:

[code=text]
Cannot find icon: /usr/share/freecad/Mod/Web/Resources/icons/WebWorkbench.svg
Program received signal SIGSEGV, Segmentation fault.
#0 /usr/lib/libc.so.6(+0x348e0) [0x7f643f05f8e0]
#1 0x7f64404ff9c0 in QPlainTextEdit::setWordWrapMode(QTextOption::WrapMode) from /usr/lib/libQtGui.so.4+0
#2 0x7f6441c2b2a1 in Gui::Dialog::DlgGeneralImp::saveSettings() from /usr/lib/freecad/lib/libFreeCADGui.so+0x211
#3 0x7f6441c3091c in Gui::Dialog::DlgPreferencesImp::applyChanges() from /usr/lib/freecad/lib/libFreeCADGui.so+0x10c
#4 0x7f6441c30e0e in Gui::Dialog::DlgPreferencesImp::accept() from /usr/lib/freecad/lib/libFreeCADGui.so+0xe
#5 0x7f643fb21c9d in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) from /usr/lib/libQtCore.so.4+0x79d
#6 0x7f643fb21c9d in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) from /usr/lib/libQtCore.so.4+0x79d
#7 0x7f64406dec93 in QAbstractButton::clicked(bool) from /usr/lib/libQtGui.so.4+0x43
#8 /usr/lib/libQtGui.so.4(+0x5ad2b7) [0x7f644041a2b7]
#9 /usr/lib/libQtGui.so.4(+0x5ae7bb) [0x7f644041b7bb]
#10 0x7f644041b8e5 in QAbstractButton::mouseReleaseEvent(QMouseEvent*) from /usr/lib/libQtGui.so.4+0x75
#11 0x7f64400a5478 in QWidget::event(QEvent*) from /usr/lib/libQtGui.so.4+0x3c8
#12 0x7f64400511f4 in QApplicationPrivate::notify_helper(QObject*, QEvent*) from /usr/lib/libQtGui.so.4+0x94
#13 0x7f6440058a02 in QApplication::notify(QObject*, QEvent*) from /usr/lib/libQtGui.so.4+0xde2
#14 0x7f6441b2d229 in Gui::GUIApplication::notify(QObject*, QEvent*) from /usr/lib/freecad/lib/libFreeCADGui.so+0x89
#15 0x7f643fb0de9e in QCoreApplication::notifyInternal(QObject*, QEvent*) from /usr/lib/libQtCore.so.4+0x8e
#16 0x7f644005762d in QApplicationPrivate::sendMouseEvent(QWidget*, QMouseEvent*, QWidget*, QWidget*, QWidget**, QPointer<QWidget>&, bool) from /usr/lib/libQtGui.so.4+0x13d
#17 /usr/lib/libQtGui.so.4(+0x263d5b) [0x7f64400d0d5b]
#18 0x7f64400cfb29 in QApplication::x11ProcessEvent(_XEvent*) from /usr/lib/libQtGui.so.4+0x1119
#19 /usr/lib/libQtGui.so.4(+0x28b215) [0x7f64400f8215]
#20 /usr/lib/libglib-2.0.so.0(g_main_context_dispatch+0x2e8) [0x7f6439bd9368]
#21 /usr/lib/libglib-2.0.so.0(+0x4c5b1) [0x7f6439bd95b1]
#22 /usr/lib/libglib-2.0.so.0(g_main_context_iteration+0x2e) [0x7f6439bd963e]
#23 0x7f643fb3c4b8 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) from /usr/lib/libQtCore.so.4+0x78
#24 /usr/lib/libQtGui.so.4(+0x28b3a8) [0x7f64400f83a8]
#25 0x7f643fb0c224 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) from /usr/lib/libQtCore.so.4+0x44
#26 0x7f643fb0c58f in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) from /usr/lib/libQtCore.so.4+0x1bf
#27 0x7f64405221e8 in QDialog::exec() from /usr/lib/libQtGui.so.4+0xe8
#28 0x7f6441b6aa93 in StdCmdDlgPreferences::activated(int) from /usr/lib/freecad/lib/libFreeCADGui.so+0x43
#29 0x7f6441b58e1b in Gui::Command::invoke(int) from /usr/lib/freecad/lib/libFreeCADGui.so+0x7b
#30 0x7f643fb21c9d in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) from /usr/lib/libQtCore.so.4+0x79d
#31 0x7f644004b2f3 in QAction::triggered(bool) from /usr/lib/libQtGui.so.4+0x43
#32 0x7f644004c77b in QAction::activate(QAction::ActionEvent) from /usr/lib/libQtGui.so.4+0xbb
#33 /usr/lib/libQtGui.so.4(+0x62f005) [0x7f644049c005]
#34 /usr/lib/libQtGui.so.4(+0x6339f5) [0x7f64404a09f5]
#35 0x7f64400a5478 in QWidget::event(QEvent*) from /usr/lib/libQtGui.so.4+0x3c8
#36 0x7f64404a477c in QMenu::event(QEvent*) from /usr/lib/libQtGui.so.4+0x6c
#37 0x7f64400511f4 in QApplicationPrivate::notify_helper(QObject*, QEvent*) from /usr/lib/libQtGui.so.4+0x94
#38 0x7f6440058a02 in QApplication::notify(QObject*, QEvent*) from /usr/lib/libQtGui.so.4+0xde2
#39 0x7f6441b2d229 in Gui::GUIApplication::notify(QObject*, QEvent*) from /usr/lib/freecad/lib/libFreeCADGui.so+0x89
#40 0x7f643fb0de9e in QCoreApplication::notifyInternal(QObject*, QEvent*) from /usr/lib/libQtCore.so.4+0x8e
#41 0x7f644005762d in QApplicationPrivate::sendMouseEvent(QWidget*, QMouseEvent*, QWidget*, QWidget*, QWidget**, QPointer<QWidget>&, bool) from /usr/lib/libQtGui.so.4+0x13d
#42 /usr/lib/libQtGui.so.4(+0x263b5e) [0x7f64400d0b5e]
#43 0x7f64400cfb29 in QApplication::x11ProcessEvent(_XEvent*) from /usr/lib/libQtGui.so.4+0x1119
#44 /usr/lib/libQtGui.so.4(+0x28b215) [0x7f64400f8215]
#45 /usr/lib/libglib-2.0.so.0(g_main_context_dispatch+0x2e8) [0x7f6439bd9368]
#46 /usr/lib/libglib-2.0.so.0(+0x4c5b1) [0x7f6439bd95b1]
#47 /usr/lib/libglib-2.0.so.0(g_main_context_iteration+0x2e) [0x7f6439bd963e]
#48 0x7f643fb3c4b8 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) from /usr/lib/libQtCore.so.4+0x78
#49 /usr/lib/libQtGui.so.4(+0x28b3a8) [0x7f64400f83a8]
#50 0x7f643fb0c224 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) from /usr/lib/libQtCore.so.4+0x44
#51 0x7f643fb0c58f in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) from /usr/lib/libQtCore.so.4+0x1bf
#52 0x7f643fb11de0 in QCoreApplication::exec() from /usr/lib/libQtCore.so.4+0xa0
#53 0x7f6441ade2b2 in Gui::Application::runApplication() from /usr/lib/freecad/lib/libFreeCADGui.so+0x1532
#54 /usr/bin/freecad(main+0x713) [0x55ee7024c083]
#55 /usr/lib/libc.so.6(__libc_start_main+0xea) [0x7f643f04bf4a]
#56 /usr/bin/freecad(_start+0x2a) [0x55ee7024d2da]
[/code]

Kunda1

2018-05-07 02:22

manager   ~0011235

Last edited: 2018-05-07 02:23

View 2 revisions

@eduardosm
FYI, You can also use the latest appimage from: https://github.com/FreeCAD/FreeCAD/releases/tag/0.18_pre
Also heads up: https://forum.freecadweb.org/viewtopic.php?f=4&t=28183

Edit:
I can't recreate on the latest appImage: FreeCAD_0.18.13662.glibc2.17-x86_64.AppImage
[code=text]OS: "Manjaro Linux"
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.18.13662 (Git) AppImage
Build type: None
Branch: master
Hash: 8d4f31f0216b2765615c2e3d096b8efa68e508c8
Python version: 2.7.6
Qt version: 4.8.6
Coin version: 4.0.0a
OCC version: 7.2.0
Locale: English/UnitedStates (en_US)
[/code]

Kunda1

2018-05-07 02:25

manager   ~0011236

This is an Arch issue i bet.
@sgrogan && @sgrogan1 I think the issue is related to https://forum.freecadweb.org/viewtopic.php?f=4&t=28183

wmayer

2018-05-08 13:29

administrator   ~0011238

Already fixed in master with:
https://github.com/FreeCAD/FreeCAD/commit/32973995423007a59cd18799c63383150811d1a7

Applied fix to v0.17:
https://github.com/FreeCAD/FreeCAD/commit/3bb5ff4e70c0c526f2d9dd69b1004155b2f527f2

Issue History

Date Modified Username Field Change
2018-05-06 12:45 eduardosm New Issue
2018-05-06 12:45 eduardosm File Added: console.txt
2018-05-07 02:08 Kunda1 Note Added: 0011234
2018-05-07 02:22 Kunda1 Note Added: 0011235
2018-05-07 02:23 Kunda1 Note Edited: 0011235 View Revisions
2018-05-07 02:24 Kunda1 Assigned To => sgrogan1
2018-05-07 02:24 Kunda1 Status new => assigned
2018-05-07 02:24 Kunda1 Target Version => 0.18
2018-05-07 02:25 Kunda1 Note Added: 0011236
2018-05-08 13:29 wmayer Status assigned => closed
2018-05-08 13:29 wmayer Resolution open => fixed
2018-05-08 13:29 wmayer Fixed in Version => 0.17
2018-05-08 13:29 wmayer Note Added: 0011238