View Issue Details

IDProjectCategoryView StatusLast Update
0000346FreeCADBugpublic2011-07-31 14:50
ReporterpperisinAssigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Versiontrunk 
Target VersionFixed in Version0.12 
Summary0000346: Sketch, pad and pocket look weird on mirrored shapes
DescriptionHi,

Create a box and mirror it. Now select one face on it and create a sketch on it. You will see that the sketc looks weird in the face of mirrored object (compare it to sketch on original box).

Also, Pad and pocket do weird things on mirrored objects. they both do pocket, but without removing extra part or something.

anyway, take a look.

Regards,
Petar Perisin
Additional Informationtested on win7 32bit.
TagsNo tags attached.

Activities

Jriegel

2011-05-17 09:58

administrator   ~0000830

I can confirm that behavior. Seams that mirroring create a inside out solid which lead the sketch and Sketch-based features to work in the wrong direction.

wmayer

2011-07-30 11:56

administrator   ~0000958

I guess the problem is in Part2DObject::positionBySupport() because this calculates the placement for the sketch and apparently make it pointing into the wrong direction.

When checking the orientations of the faces of a mirrored box then they indeed seem to change. But I can't imagine that this is wrong because a normal box has three forward shapes and three reversed faces and also the mirrored box. It's only that forward becomes reversed and the other way round.

wmayer

2011-07-31 14:50

administrator   ~0000962

Fixed in r4712.

Apparently the planes of a mirrored objects turn their coordinate system into a left-handed system. That's why it later tries to pad/pocket into the wrong direction.

Note: In case you have any project files with such sketch you must redo them because the stored coordinates there are also wrong and thus won't work by recomputing the document.

Issue History

Date Modified Username Field Change
2011-05-03 08:21 pperisin New Issue
2011-05-17 09:58 Jriegel Note Added: 0000830
2011-05-17 09:58 Jriegel Status new => confirmed
2011-07-30 11:56 wmayer Note Added: 0000958
2011-07-31 14:50 wmayer Note Added: 0000962
2011-07-31 14:50 wmayer Status confirmed => closed
2011-07-31 14:50 wmayer Resolution open => fixed
2011-07-31 14:50 wmayer Fixed in Version => 0.12