View Issue Details

IDProjectCategoryView StatusLast Update
0003445AssemblyBugpublic2018-07-03 02:31
ReporterEverymanAssigned To 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
PlatformMacOS OS XOS Version10.13.4 (17E199)
Product Version0.17 
Target VersionFixed in Version0.18 
Summary0003445: Import Part not working in Assembly2
DescriptionAssembly2: when pressing “Import Part from another CAD document”.
Should present a file selection dialogue. Does nothing.
Steps To Reproduce1) Create New File
2) Select Assembly 2 workbench
3) Press Import Part button
Nothing happens (should open dialogue box)
Additional Information

============== Log:
'NoneType' object has no attribute 'activeWindow'Running the Python command 'importPart' failed:
Traceback (most recent call last):
File "/Users/chris/Library/Preferences/FreeCAD/Mod/assembly2/importPart.py", line 137, in Activated
QtGui.qApp.activeWindow(),
'NoneType' object has no attribute ‘activeWindow'
==============

(Broken in this build)
===============
OS: Mac OS X
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.17.13519 (Git)
Build type: Release
Branch: (HEAD detached at 1a8b868)
Hash: 1a8b868018f45ea486c0023fdbfeb06febc1fb89
Python version: 2.7.14
Qt version: 5.10.1
Coin version: 4.0.0a
OCC version: 7.2.0
Locale: English/UnitedKingdom (en_GB)
===============

(Working in this build)
===============
OS: Mac OS X
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.17.13309 (Git)
Build type: Release
Branch: (HEAD detached at 5c76aff)
Hash: 5c76affc22eaffbb750e96e737826c4e924a21de
Python version: 2.7.14
Qt version: 5.6.2
Coin version: 4.0.0a
OCC version: 7.1.0
Locale: English/UnitedKingdom (en_GB)
================
TagsNo tags attached.

Activities

Kunda1

2018-04-24 11:03

manager   ~0011188

Please open forum thread on the forum especially since Assembly2 is not part of FreeCAD core in fact the issue queue for it is at https://github.com/hamish2014/FreeCAD_assembly2

easyw-fc

2018-06-20 16:03

reporter   ~0011457

this issue could be simple solved changing:
QtGui.qApp.activeWindow()
to
QtGui.QApplication.activeWindow()

Unfortunately nobody offered to maintain A2 WB ... so no way to patch this

Kunda1

2018-06-22 13:02

manager   ~0011461

@easyw-fc who has access to the repo, if certain changes are obvious maybe we could at least update those?

Everyman

2018-06-28 08:27

reporter   ~0011474

I have set a pull request with the suggested edits, which seem to fix the problem for me. But I am not experienced with Assembly2 - so please test before deploying.
https://github.com/hamish2014/FreeCAD_assembly2/pull/154

Kunda1

2018-06-28 13:11

manager   ~0011475

Thank you @everyman
Please take a look at the discussion https://forum.freecadweb.org/./viewtopic.php?f=20&t=29432 in regards to Assembly2 and its future.

Kunda1

2018-07-03 02:31

manager   ~0011485

Merged: https://github.com/hamish2014/FreeCAD_assembly2/commit/766ed37ebbb00fb7ee1f9c96bd24d342dd62bb4c

Thank you!
Closing ticket

Issue History

Date Modified Username Field Change
2018-04-24 09:34 Everyman New Issue
2018-04-24 11:03 Kunda1 Status new => feedback
2018-04-24 11:03 Kunda1 Note Added: 0011188
2018-06-20 16:03 easyw-fc Note Added: 0011457
2018-06-22 13:02 Kunda1 Note Added: 0011461
2018-06-28 08:27 Everyman Note Added: 0011474
2018-06-28 08:27 Everyman Status feedback => new
2018-06-28 13:11 Kunda1 Note Added: 0011475
2018-06-28 13:11 Kunda1 Status new => confirmed
2018-07-03 02:31 Kunda1 Status confirmed => closed
2018-07-03 02:31 Kunda1 Resolution open => fixed
2018-07-03 02:31 Kunda1 Fixed in Version => 0.18
2018-07-03 02:31 Kunda1 Note Added: 0011485