View Issue Details

IDProjectCategoryView StatusLast Update
0003444FreeCADBugpublic2018-09-26 15:49
ReporterAshlynAssigned To 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Platformx86_64OSLinux MintOS Version18.2
Product Version0.17 
Target VersionFixed in Version0.18 
Summary0003444: Exported models do not include Body Object transformations
DescriptionTransformations applied to body objects do not appear in exported files. All body objects will be at [0,0,0]. I have tested this with VRML (.wrl) and Wavefront (.obj) so far.
Steps To Reproduce[list=1]
[*] Start new project
[*] Create new body object
[*] Create a primitive in object
[*] Translate body object (for example to [10mm,0,0])
[*] Export as Wavefront (.obj)
[*] Import into another 3D application (Blender for example)
[/list]
Additional InformationOS: Linux Mint 18.2 Sonya
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.17.13515 (Git)
Build type: None
Branch: releases/FreeCAD-0-17
Hash: e17b340949b75a226cc7d89989b0aa238ccfc75f
Python version: 2.7.12
Qt version: 4.8.7
Coin version: 4.0.0a
OCC version: 7.2.0
Locale: English/Australia (en_AU)
Tagsconversion, export, file format, VRML

Relationships

related to 0003486 closedwmayer Improve VRML export for more complex structures 

Activities

Ashlyn

2018-04-23 21:20

reporter  

Kunda1

2018-04-23 21:53

manager   ~0011187

Please open a forum thread in the Help section to discuss with the FC community.

Kunda1

2018-05-31 16:48

manager   ~0011334

Forum discussion thread: https://forum.freecadweb.org/viewtopic.php?f=8&t=29051

wmayer

2018-09-26 15:49

administrator   ~0011856

Exporting to obj or any other mesh format works as expected now.

What does not work is the VRML export because when selecting a body or part container and reloading the VRML file the view is empty. Only when selecting an object inside a part or body the exported object is visible afterwards but then it hasn't applied the transformation of the parent object.

To me the VRML issue is not a transformation thing but something else. The ticket #3486 is dedicated to the VRML issue so that this ticket can now be considered as fixed.

Issue History

Date Modified Username Field Change
2018-04-23 21:20 Ashlyn New Issue
2018-04-23 21:20 Ashlyn Tag Attached: bugtracker
2018-04-23 21:20 Ashlyn Tag Attached: conversion
2018-04-23 21:20 Ashlyn Tag Attached: export
2018-04-23 21:20 Ashlyn Tag Attached: file format
2018-04-23 21:20 Ashlyn Tag Attached: translation
2018-04-23 21:20 Ashlyn Tag Attached: VRML
2018-04-23 21:20 Ashlyn File Added: Screenshot from 2018-04-24 04-37-25.mp4.png
2018-04-23 21:20 Ashlyn File Added: Screenshot from 2018-04-24 04-37-25.mp4 - 1.png
2018-04-23 21:53 Kunda1 Note Added: 0011187
2018-04-23 21:53 Kunda1 Status new => feedback
2018-04-23 21:54 Kunda1 Tag Detached: bugtracker
2018-04-23 21:54 Kunda1 Tag Detached: translation
2018-05-31 14:59 Kunda1 Relationship added related to 0003486
2018-05-31 16:48 Kunda1 Note Added: 0011334
2018-09-26 15:49 wmayer Status feedback => closed
2018-09-26 15:49 wmayer Resolution open => fixed
2018-09-26 15:49 wmayer Fixed in Version => 0.18
2018-09-26 15:49 wmayer Note Added: 0011856