View Issue Details

IDProjectCategoryView StatusLast Update
0003417FreeCADBugpublic2018-09-25 13:30
Reporterpager48Assigned Towmayer 
PriorityhighSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version0.18 
Target VersionFixed in Version0.18 
Summary0003417: Zooming out causes part to orbit when rotating
DescriptionZooming is a common operation thus part rotation is commonly buggy.
Steps To Reproduce-Open attached part
-Open part work bench
-Select "Fits the whole contents on the screen" or press F
-Rotate and notice ideal rotation
-Zoom out
-Rotate and notice buggy rotating (part orbits)

Results: Part rotates
TagsNo tags attached.

Activities

pager48

2018-04-01 02:26

reporter  

part.FCStd (505,857 bytes)

Kunda1

2018-04-01 12:42

manager   ~0011094

No version info was posted. No forum thread was opened pre-ticket.

easyw-fc

2018-04-01 17:48

reporter   ~0011098

Last edited: 2018-04-01 17:48

View 2 revisions

it is a PEBCAK IMO
here the forum thread
https://forum.freecadweb.org/viewtopic.php?f=8&t=27662
The user doesn't use the Zoom-out Zoom-in correctly, then the central pivot will change.
Here my reply with a screen-cast to achieve the desired result
https://forum.freecadweb.org/viewtopic.php?f=8&t=27662&start=20

Kunda1

2018-04-25 13:02

manager   ~0011196

Do we have consensus to close this ticket ?
@NormandC ?

normandc

2018-04-26 01:55

manager   ~0011199

In fact this bug report is so poorly worded that this might not be about zooming, but the fact that sometimes, a section of the model disappears when rotating the view. But who knows.

@pager48 there's a really big and I mean [size=125]BIG[/size] yellow banner at the top that says you should open a forum topic FIRST before creating a report. This is not your first bug report, you have 14 others and in [u]none of them[/u] did you create a forum topic first. DO NOT OPEN FURTHER BUG REPORTS WITHOUT FIRST OPENING A FORUM TOPIC.

And yes, I'm shouting!!!

wmayer

2018-09-25 13:30

administrator   ~0011837

The standard behaviour of Coin3d (OpenInventor) is that the pivot is always the center of the 3d view because this is where an SoCamera node is pointing to.
And this of course means that when zooming out and moving the model far outside the center then it makes big jumps when rotating it.

So far this is absolutely correct behaviour but indeed might be inconvenient in some scenarios. To make sure you rotate around a point of the model you have to do a simple click with the mouse wheel somewhere on the model. The object then moves to the center of the 3d view (or more precisely: the camera moves its position so that it looks at the model).

With commit https://github.com/FreeCAD/FreeCAD/commit/d4987d088f8897c62307feb549536486e4dbbb9c#diff-2da9b1980fb27ebefcfdc0f06017bd36 a new option "drag at cursor" has been implemented where you now can directly rotate around any point on a model in the 3d view.

Issue History

Date Modified Username Field Change
2018-04-01 02:26 pager48 New Issue
2018-04-01 02:26 pager48 File Added: part.FCStd
2018-04-01 12:42 Kunda1 Note Added: 0011094
2018-04-01 17:48 easyw-fc Note Added: 0011098
2018-04-01 17:48 easyw-fc Note Edited: 0011098 View Revisions
2018-04-25 13:02 Kunda1 Note Added: 0011196
2018-04-26 01:55 normandc Note Added: 0011199
2018-09-25 13:30 wmayer Assigned To => wmayer
2018-09-25 13:30 wmayer Status new => closed
2018-09-25 13:30 wmayer Resolution open => fixed
2018-09-25 13:30 wmayer Fixed in Version => 0.18
2018-09-25 13:30 wmayer Note Added: 0011837