View Issue Details

IDProjectCategoryView StatusLast Update
0000340FreeCADFeaturepublic2012-04-02 05:21
ReporterwmayerAssigned To 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version0.13 
Summary0000340: Make mesh 4-node parabolic instead of plain 3-node
DescriptionSopTunnan said:

Hi, I'm an engineer using CATIA V5 on a daily basis in a Nordic car company. In my work I must verify every step of design change for the track record and possibility to see any progress / trends. For the results to be comparable over time and accuracy I / we use specialists in calculation (it's a huge department in it self) who in turn uses Abaqus and Ansa in their work. A while ago we tried to match results from CATIA:s native mesh and calculation function with results from Abaqus and Ansa. Guess what, the results from CV5 wasn't even on the same planet as the results from A&A, not to mention compared to reality (which is constantly tested by another department).

 This lead me to thinking about having a real and useful mesh generator + solver embedded in the CAD program directly. And as we all know by now, CV5:s owner, Dassault, bought Abaqus a while ago. But the problem persists, the mesh is still made of 3-nodes. And why should that be of any concern you say? Well, when we tested CV5 against A&A we noticed that in order to get the results within in the same universe we had to add an extra node between corners on the mesh in CV5, it est, parabolic (Ansa makes a 4-node mesh with additional nodes between the corner nodes). By this we concluded that a 3-node mesh was way too stiff compared to the reality regardless the extra nodes put in.

 Now to my post here: if you guys could make the mesh generator producing 4-node parabolic meshes AND have it automagically linked to the 3D-geometry it would revolutionise the whole development process. This because the engineers / CAD-slaves must first make changes to their geometry and then have it recalculated by the calculating staff. It takes bloody ages!!! The calculating staff are always too few compared to us CAD:ies (their salaries are way higher than ours) and therefor a design loop is much too time consuming. By integrating their tool (CAE) into our tool (CAD) we could shorten the design loop to as little as 1/7 of the present time consumption.
 And since you where so kindly starting the FreeCAD project I thought it would be a smart move to make this the best CAD / CAE software there is before you've got too far in your development.
 Of course the CAE-guys must stay in the background but they wouldn't need to check every tiny winy little step to help us see if we are heading in the right direction. They could concentrate on the really heavy calculations such as whole car NVH or crash simulation which demands huge clusters of specialised hardware / software.

 If I could wish for one more feature it would be multithreading, staying on all the time. In CV5 it's turned on only when meshing and only if using a very specific Intel CPU and with a specialised program from the same company, idiotic!
TagsNo tags attached.

Activities

wmayer

2011-04-14 06:24

administrator   ~0000787

jriegel said:
Hi,
 thanks for the description.

 We started already a FEM Module/Workbench. We using SMESH which is
 a spinof of SALOME and utilize the meshers.
 Its able to work with triangular and quad meshes and the reference to the

 faces/edges/points stays intact.

 Unfortunately Im engaged in the development of the constraint sketcher
 for FreeCAD and have no time to finisch the FEM workbench at the moment.

 Sorry

wmayer

2012-04-02 05:21

administrator   ~0001844

In git 2a3317113fed5f404b7c9075ae645c7a9ce141ac there is a dialog now to parametrize how to create quad meshes

Issue History

Date Modified Username Field Change
2011-04-14 06:22 wmayer New Issue
2011-04-14 06:24 wmayer Note Added: 0000787
2011-04-14 06:24 wmayer Description Updated
2011-05-17 10:38 Jriegel Status new => acknowledged
2012-04-02 05:21 wmayer Note Added: 0001844
2012-04-02 05:21 wmayer Status acknowledged => closed
2012-04-02 05:21 wmayer Resolution open => fixed
2012-04-02 05:21 wmayer Fixed in Version => 0.13