View Issue Details

IDProjectCategoryView StatusLast Update
0003346PathFeaturepublic2020-05-09 22:55
Reportersliptonic Assigned Tosliptonic  
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version0.18 
Target Version0.19 
Summary0003346: Provide run-time estimation for Path operations and jobs
DescriptionCAM programmers would like to see an estimation how long an operation will take to complete.

Calculating the actual run-time is enormously complicated because acceleration of the path elements is unknown and machine dependent but an estimate within even 5% accuracy is useful.
Additional Informationhttps://forum.freecadweb.org/viewtopic.php?f=15&t=26864
TagsNo tags attached.
FreeCAD Information

Activities

Kunda1

2019-04-06 19:09

administrator   ~0013005

Changing from 'Feedback' to 'Acknowledged' unless this should be 'Confirmed' since @sliptonic created the ticket ?

dubstar_04

2020-04-23 14:20

developer   ~0014368

https://github.com/FreeCAD/FreeCAD/pull/3378

sliptonic

2020-05-09 22:55

developer   ~0014412

Fix committed to master branch.

Related Changesets

FreeCAD: master 8adadcf2

2020-04-22 23:07:52

sliptonic


Committer: GitHub Details Diff
Merge pull request 0003378 from dubstar-04/feature/CycleTimeEstimate

[PATH] feature/cycle time estimate - fixes 0003346
Affected Issues
0003346
mod - src/Mod/Path/App/Path.cpp Diff File
mod - src/Mod/Path/App/Path.h Diff File
mod - src/Mod/Path/App/PathPy.xml Diff File
mod - src/Mod/Path/App/PathPyImp.cpp Diff File
mod - src/Mod/Path/PathScripts/PathJob.py Diff File
mod - src/Mod/Path/PathScripts/PathOp.py Diff File

Issue History

Date Modified Username Field Change
2018-02-11 15:13 sliptonic New Issue
2019-01-22 05:27 sliptonic Status new => feedback
2019-01-22 05:27 sliptonic Target Version 0.18 => 0.19
2019-04-06 19:09 Kunda1 Status feedback => acknowledged
2019-04-06 19:09 Kunda1 Note Added: 0013005
2019-09-04 07:19 dubstar_04 Assigned To => dubstar_04
2019-09-04 07:19 dubstar_04 Status acknowledged => assigned
2019-09-04 12:16 Kunda1 Summary Provide run0time estimation for Path operations and jobs => Provide run-time estimation for Path operations and jobs
2020-04-23 14:20 dubstar_04 Note Added: 0014368
2020-04-23 14:20 dubstar_04 Status assigned => resolved
2020-05-09 22:55 sliptonic Changeset attached => FreeCAD master 8adadcf2
2020-05-09 22:55 sliptonic Note Added: 0014412
2020-05-09 22:55 sliptonic Assigned To dubstar_04 => sliptonic
2020-05-09 22:55 sliptonic Status resolved => closed
2020-05-09 22:55 sliptonic Resolution open => fixed