View Issue Details

IDProjectCategoryView StatusLast Update
0003310FreeCADBugpublic2021-02-27 13:24
ReporterGoulou Assigned Tochennes  
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
PlatformLinuxOS4.9.56-21 x86_64OS VersionFedora 25
Product Version0.17 
Target Version0.20Fixed in Version0.20 
Summary0003310: Application crash when adding a fillet on an edge (SIGSEGV) (Target OCC7.5)
DescriptionWhen adding a fillet on a specific edge, FreeCAD crashes.
I am running latest version from GIT (commit 8ba4e0c5d0284fd8a631d24db607f0d0039991d1).
Steps To Reproduce-open the file support.fcstd with FreeCAD
-select the PartDesign workbench
-Select the edge highlighted on the screenshot
-click the icon "Make a fillet on a edge, face or body"
Additional InformationFull stacktrace :

Program received signal SIGSEGV, Segmentation fault.
#0  /lib64/libc.so.6(+0x35950) [0x78e71438e950]
#1  0x78e682ea08e0 in BRep_ListIteratorOfListOfCurveRepresentation::BRep_ListIteratorOfListOfCurveRepresentation(BRep_ListOfCurveRepresentation const&) from /lib64/libTKBRep.so.10+0
0000002  0x78e682e9b57e in BRep_Tool::CurveOnSurface(TopoDS_Edge const&, Handle_Geom_Surface const&, TopLoc_Location const&, double&, double&) from /lib64/libTKBRep.so.10+0x6e
0000003  0x78e682e9bf69 in BRep_Tool::CurveOnSurface(TopoDS_Edge const&, TopoDS_Face const&, double&, double&) from /lib64/libTKBRep.so.10+0x99
0000004  0x78e682eacb72 in BRepAdaptor_Curve2d::Initialize(TopoDS_Edge const&, TopoDS_Face const&) from /lib64/libTKBRep.so.10+0x82
0000005  0x78e68a56564f in ChFi3d_Builder::StartSol(Handle_ChFiDS_Spine const&, Handle_BRepAdaptor_HSurface&, gp_Pnt2d&, Handle_BRepAdaptor_HCurve2d&, double&, Handle_ChFiDS_SurfData const&, bool, int, Handle_BRepAdaptor_HSurface&, Handle_BRepAdaptor_HCurve2d&, bool&, bool&, bool&, bool&, Handle_BRepAdaptor_HSurface&, gp_Pnt2d&, bool, TopoDS_Vertex const&) const from /lib64/libTKFillet.so.10+0x132f
0000006  0x78e68a56bc54 in ChFi3d_Builder::PerformSetOfSurfOnElSpine(Handle_ChFiDS_HElSpine const&, Handle_ChFiDS_Stripe&, Handle_BRepTopAdaptor_TopolTool&, Handle_BRepTopAdaptor_TopolTool&, bool) from /lib64/libTKFillet.so.10+0x834
0000007  0x78e68a56e822 in ChFi3d_Builder::PerformSetOfKGen(Handle_ChFiDS_Stripe&, bool) from /lib64/libTKFillet.so.10+0x102
0000008  0x78e68a571d45 in ChFi3d_Builder::PerformSetOfSurf(Handle_ChFiDS_Stripe&, bool) from /lib64/libTKFillet.so.10+0x65
0000009  0x78e68a536242 in ChFi3d_Builder::Compute() from /lib64/libTKFillet.so.10+0x3e2
0000010  0x78e68a6edc09 in BRepFilletAPI_MakeFillet::Build() from /lib64/libTKFillet.so.10+0x29
0000011  0x78e69519d1a8 in PartDesign::Fillet::execute() from /home/user/FreeCAD/FreeCAD/build/Mod/PartDesign/_PartDesign.so+0x3f8
0000012  0x78e71dd1a34d in App::DocumentObject::recompute() from /home/user/FreeCAD/FreeCAD/build/lib/libFreeCADApp.so+0x6d
0000013  0x78e694c354cb in Part::Feature::recompute() from /home/user/FreeCAD/FreeCAD/build/Mod/Part/Part.so+0xb
0000014  0x78e71dce700c in App::Document::_recomputeFeature(App::DocumentObject*) from /home/user/FreeCAD/FreeCAD/build/lib/libFreeCADApp.so+0x8c
0000015  0x78e71dceaf20 in App::Document::recompute() from /home/user/FreeCAD/FreeCAD/build/lib/libFreeCADApp.so+0x1d0
0000016  0x78e71dd42e74 in App::DocumentPy::recompute(_object*) from /home/user/FreeCAD/FreeCAD/build/lib/libFreeCADApp.so+0x34
0000017  0x78e71dd42fb3 in App::DocumentPy::staticCallback_recompute(_object*, _object*) from /home/user/FreeCAD/FreeCAD/build/lib/libFreeCADApp.so+0x23
0000018  /lib64/libpython2.7.so.1.0(PyEval_EvalFrameEx+0x5f97) [0x78e71d59ac57]
0000019  /lib64/libpython2.7.so.1.0(PyEval_EvalCodeEx+0x8dc) [0x78e71d59e5ec]
0000020  /lib64/libpython2.7.so.1.0(PyEval_EvalCode+0x19) [0x78e71d59e6d9]
0000021  /lib64/libpython2.7.so.1.0(+0x155d7f) [0x78e71d574d7f]
0000022  /lib64/libpython2.7.so.1.0(PyRun_StringFlags+0x66) [0x78e71d574ec6]
0000023  0x78e71d915d56 in Base::InterpreterSingleton::runString[abi:cxx11](char const*) from /home/user/FreeCAD/FreeCAD/build/lib/libFreeCADBase.so+0x56
0000024  0x78e71e413b04 in Gui::Command::doCommand(Gui::Command::DoCmd_Type, char const*, ...) from /home/user/FreeCAD/FreeCAD/build/lib/libFreeCADGui.so+0x114
0000025  0x78e71e414526 in Gui::Command::updateActive() from /home/user/FreeCAD/FreeCAD/build/lib/libFreeCADGui.so+0x26
0000026  0x78e680e6a69b in finishFeature(Gui::Command const*, std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> > const&, App::DocumentObject*, bool) from /home/user/FreeCAD/FreeCAD/build/Mod/PartDesign/PartDesignGui.so+0x5b
0000027  0x78e680e6b060 in finishDressupFeature(Gui::Command const*, std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> > const&, Part::Feature*, std::vector<std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> >, std::allocator<std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> > > > const&) from /home/user/FreeCAD/FreeCAD/build/Mod/PartDesign/PartDesignGui.so+0x440
0000028  0x78e680e6d55a in makeChamferOrFillet(Gui::Command*, std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> > const&) from /home/user/FreeCAD/FreeCAD/build/Mod/PartDesign/PartDesignGui.so+0x11a
0000029  0x78e680e6d676 in CmdPartDesignFillet::activated(int) from /home/user/FreeCAD/FreeCAD/build/Mod/PartDesign/PartDesignGui.so+0x36
0000030  0x78e71e417dfc in Gui::Command::invoke(int) from /home/user/FreeCAD/FreeCAD/build/lib/libFreeCADGui.so+0x5c
0000031  0x78e7155c4090 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) from /lib64/libQtCore.so.4+0x4d0
0000032  0x78e7160a0062 in QAction::triggered(bool) from /lib64/libQtGui.so.4+0x42
0000033  0x78e7160a13c3 in QAction::activate(QAction::ActionEvent) from /lib64/libQtGui.so.4+0x83
0000034  /lib64/libQtGui.so.4(+0x5c84c3) [0x78e71647b4c3]
0000035  0x78e71647b614 in QAbstractButton::mouseReleaseEvent(QMouseEvent*) from /lib64/libQtGui.so.4+0x74
0000036  0x78e716540b5a in QToolButton::mouseReleaseEvent(QMouseEvent*) from /lib64/libQtGui.so.4+0xa
0000037  0x78e7160fc710 in QWidget::event(QEvent*) from /lib64/libQtGui.so.4+0x290
0000038  0x78e7160a5ecc in QApplicationPrivate::notify_helper(QObject*, QEvent*) from /lib64/libQtGui.so.4+0x8c
#39  0x78e7160ae547 in QApplication::notify(QObject*, QEvent*) from /lib64/libQtGui.so.4+0x1a47
#40  0x78e71e3f46c1 in Gui::GUIApplication::notify(QObject*, QEvent*) from /home/user/FreeCAD/FreeCAD/build/lib/libFreeCADGui.so+0x41
0000041  0x78e7155afeed in QCoreApplication::notifyInternal(QObject*, QEvent*) from /lib64/libQtCore.so.4+0x8d
0000042  0x78e7160ac56b in QApplicationPrivate::sendMouseEvent(QWidget*, QMouseEvent*, QWidget*, QWidget*, QWidget**, QPointer<QWidget>&, bool) from /lib64/libQtGui.so.4+0x14b
0000043  /lib64/libQtGui.so.4(+0x273fe9) [0x78e716126fe9]
0000044  0x78e71612599c in QApplication::x11ProcessEvent(_XEvent*) from /lib64/libQtGui.so.4+0xc9c
0000045  /lib64/libQtGui.so.4(+0x29b409) [0x78e71614e409]
0000046  /lib64/libglib-2.0.so.0(g_main_context_dispatch+0x162) [0x78e70ddfde52]
0000047  /lib64/libglib-2.0.so.0(+0x4a1d0) [0x78e70ddfe1d0]
0000048  /lib64/libglib-2.0.so.0(g_main_context_iteration+0x2c) [0x78e70ddfe27c]
0000049  0x78e7155e045e in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) from /lib64/libQtCore.so.4+0x7e
0000050  /lib64/libQtGui.so.4(+0x29b5a6) [0x78e71614e5a6]
0000051  0x78e7155ae7bf in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) from /lib64/libQtCore.so.4+0x3f
0000052  0x78e7155aeb25 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) from /lib64/libQtCore.so.4+0x1b5
0000053  0x78e7155b4779 in QCoreApplication::exec() from /lib64/libQtCore.so.4+0x99
0000054  0x78e71e3b0ff2 in Gui::Application::runApplication() from /home/user/FreeCAD/FreeCAD/build/lib/libFreeCADGui.so+0x15c2
0000055  /home/user/FreeCAD/FreeCAD/build/bin/FreeCAD(main+0x85d) [0x4036bd]
0000056  /lib64/libc.so.6(__libc_start_main+0xf1) [0x78e714379431]
0000057  /home/user/FreeCAD/FreeCAD/build/bin/FreeCAD(_start+0x2a) [0x40487a]

Additional version information :

> dnf provides /usr/lib64/libTKBRep.so.10
OCE-modeling-0.17.1-2.fc25.x86_64 : OpenCASCADE CAE platform shared libraries
Repo        : fedora

> md5sum  /usr/lib64/libTKBRep.so.10
d26f41fe074bfd1fc970aad75d492e42  /usr/lib64/libTKBRep.so.10

Tagscrash, fillet, OCC 7.6, OCC Bug, upstream
FreeCAD Information

Relationships

duplicate of 0004543 resolvedchennes FreeCAD crashes when OCC fails with fillets and chamfers 

Activities

Goulou

2018-01-14 15:25

reporter  

crash_fillet_on_edge.png (27,679 bytes)   
crash_fillet_on_edge.png (27,679 bytes)   
support.fcstd (106,765 bytes)

Goulou

2018-01-14 15:26

reporter   ~0010764

Version informations :
OS: Linux
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.17.13031 (Git)
Build type: Release
Branch: master
Hash: 8ba4e0c5d0284fd8a631d24db607f0d0039991d1
Python version: 2.7.13
Qt version: 4.8.7
Coin version: 3.1.3
OCC version: 6.8.0.oce-0.17
Locale: English/UnitedStates (en_US)

wmayer

2018-01-30 15:13

administrator   ~0010899

Confirmed with:
OS: Windows 7
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.17.13188 (Git)
Build type: Debug
Branch: master
Hash: 76d27f46456ee46905361e9646b0976a38a830fd
Python version: 2.7.8
Qt version: 5.6.0
Coin version: 4.0.0a
OCC version: 7.0.0
Locale: German/Germany (de_DE)

Unfortunately, it's an OCCT issue which we are not able to fix.

Goulou

2018-02-02 20:28

reporter   ~0010914

Who should I report it to then?

Kunda1

2018-02-05 17:01

administrator   ~0010922

Added to https://forum.freecadweb.org/viewtopic.php?f=10&t=20264#p156236

Kunda1

2018-02-08 14:47

administrator   ~0010935

Upstream ticket: https://tracker.dev.opencascade.org/view.php?id=29493

Kunda1

2018-03-03 10:47

administrator   ~0010989

Upstream has targeted fix for OCC7.4

Kunda1

2019-09-01 19:41

administrator   ~0013515

Upstream bumped this to OCC7.5
tagged this ticket accordingly
updated OCC buglist https://forum.freecadweb.org/viewtopic.php?f=10&t=20264

ari

2019-09-14 10:11

reporter   ~0013595

Could you check wether this is a duplicate?
- create a fillet with r>=1.2mm on this selected edge:

forum thread I created because I didn't find this ticket earlier:
https://forum.freecadweb.org/viewtopic.php?f=3&t=39163&sid=d976b4594a9a704395d041b4472668dc
fillet crashes freecad.png (194,109 bytes)   
fillet crashes freecad.png (194,109 bytes)   
usb-c case.FCStd (15,200 bytes)

Kunda1

2020-10-08 13:54

administrator   ~0014801

Upstream ticket was was bumped to OCC 7.6 roadmap.
Tagged this ticket OCC7.6
Notated in OCC bugtracker list: https://forum.freecadweb.org/viewtopic.php?f=10&t=20264

chennes

2021-02-04 05:15

developer   ~0015258

In my testing, this is resolved by the fix discussed in 0004543.

Kunda1

2021-02-27 13:22

administrator   ~0015445

@chennes has created a downstream patch that fixes the crash. It is slowly being integrated in to downstream packages (ATM libpack is the only one but more will follow). This issue is therefore being marked as resolved. It will be closed one all packages are patched or when (if) upstream merges.

Issue History

Date Modified Username Field Change
2018-01-14 15:25 Goulou New Issue
2018-01-14 15:25 Goulou File Added: crash_fillet_on_edge.png
2018-01-14 15:25 Goulou File Added: support.fcstd
2018-01-14 15:25 Goulou Tag Attached: crash
2018-01-14 15:25 Goulou Tag Attached: fillet
2018-01-14 15:26 Goulou Note Added: 0010764
2018-01-16 14:53 Kunda1 Tag Attached: #post-to-forum
2018-01-16 14:54 Kunda1 Target Version => 0.17
2018-01-30 15:13 wmayer Status new => confirmed
2018-01-30 15:13 wmayer Target Version 0.17 =>
2018-01-30 15:13 wmayer Note Added: 0010899
2018-02-02 20:28 Goulou Note Added: 0010914
2018-02-05 16:59 Kunda1 Tag Attached: OCC Bug
2018-02-05 17:01 Kunda1 Note Added: 0010922
2018-02-05 17:15 Kunda1 Tag Attached: upstream
2018-02-08 14:47 Kunda1 Note Added: 0010935
2018-02-08 14:47 Kunda1 Tag Attached: OCC 7.3
2018-02-08 14:47 Kunda1 Tag Detached: #post-to-forum
2018-02-08 14:48 Kunda1 Summary Application crash when adding a fillet on an edge (SIGSEGV, full stacktrace available) => Application crash when adding a fillet on an edge (SIGSEGV) (Target OCC7.3)
2018-03-03 10:46 Kunda1 Tag Attached: OCC 7.4
2018-03-03 10:46 Kunda1 Tag Detached: OCC 7.3
2018-03-03 10:47 Kunda1 Note Added: 0010989
2018-03-03 10:47 Kunda1 Summary Application crash when adding a fillet on an edge (SIGSEGV) (Target OCC7.3) => Application crash when adding a fillet on an edge (SIGSEGV) (Target OCC7.4)
2019-09-01 19:41 Kunda1 Tag Detached: OCC 7.4
2019-09-01 19:41 Kunda1 Tag Attached: OCC 7.5
2019-09-01 19:41 Kunda1 Summary Application crash when adding a fillet on an edge (SIGSEGV) (Target OCC7.4) => Application crash when adding a fillet on an edge (SIGSEGV) (Target OCC7.5)
2019-09-01 19:41 Kunda1 Note Added: 0013515
2019-09-14 10:11 ari File Added: fillet crashes freecad.png
2019-09-14 10:11 ari File Added: usb-c case.FCStd
2019-09-14 10:11 ari Note Added: 0013595
2020-10-08 13:54 Kunda1 Tag Detached: OCC 7.5
2020-10-08 13:54 Kunda1 Tag Attached: OCC 7.6
2020-10-08 13:54 Kunda1 Note Added: 0014801
2021-02-04 05:15 chennes Note Added: 0015258
2021-02-06 06:49 abdullah Target Version => 0.20
2021-02-27 13:22 Kunda1 Assigned To => chennes
2021-02-27 13:22 Kunda1 Status confirmed => resolved
2021-02-27 13:22 Kunda1 Resolution open => fixed
2021-02-27 13:22 Kunda1 Fixed in Version => 0.20
2021-02-27 13:22 Kunda1 Note Added: 0015445
2021-02-27 13:24 Kunda1 Relationship added duplicate of 0004543