View Issue Details

IDProjectCategoryView StatusLast Update
0003281FreeCADBugpublic2017-12-12 20:47
ReportergitamaniAssigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformUbuntuOSGNU LinuxOS Version17.04
Product Version0.17 
Target Version0.17Fixed in Version0.17 
Summary0003281: STL object doesn't retain its rotation after change
DescriptionDoes not store rotation on imported stl objects.
Steps To ReproduceInserted a stl object, after positioning it, rotate it. When I change the position, the object returns to its original rotation.
TagsNo tags attached.

Activities

gitamani

2017-12-04 15:30

reporter  

Freecad.m4v (714,793 bytes)

Kunda1

2017-12-04 15:41

manager   ~0010516

@gitamani
2 things: please always include your full Help>About FreeCAD>Copy to clipboard
please post to your issue to the forum for exposure + bi-directionally link thread <-- ticket
Per the guidelines (at the top of this page - yellow banner)

Kunda1

2017-12-06 18:19

manager   ~0010521

Forum thread: https://forum.freecadweb.org/viewtopic.php?f=8&t=25737

Kunda1

2017-12-06 23:16

manager   ~0010525

@gitamani your presence is requested on the forum thread ^

Kunda1

2017-12-09 11:54

manager   ~0010549

Last edited: 2017-12-09 11:55

View 2 revisions

Seems to be pending on p:FreeCAD:1053: (per https://forum.freecadweb.org/viewtopic.php?f=8&t=25737#p203539 )
Workaround does also exist.

wmayer

2017-12-12 20:47

administrator   ~0010593

https://github.com/FreeCAD/FreeCAD/commit/f9892009f63142bedc5c3092e4b1c46007801247

Issue History

Date Modified Username Field Change
2017-12-04 15:30 gitamani New Issue
2017-12-04 15:30 gitamani File Added: Freecad.m4v
2017-12-04 15:41 Kunda1 Note Added: 0010516
2017-12-04 15:42 Kunda1 Tag Attached: #post-to-forum
2017-12-04 15:43 Kunda1 Priority high => normal
2017-12-04 15:43 Kunda1 Severity major => minor
2017-12-04 16:11 Kunda1 Summary Not store the rotation => STL object doesn't retain it's rotation after change
2017-12-06 18:19 Kunda1 Tag Detached: #post-to-forum
2017-12-06 18:19 Kunda1 Note Added: 0010521
2017-12-06 18:19 Kunda1 Status new => feedback
2017-12-06 23:16 Kunda1 Note Added: 0010525
2017-12-09 11:54 Kunda1 Note Added: 0010549
2017-12-09 11:54 Kunda1 Status feedback => confirmed
2017-12-09 11:54 Kunda1 Target Version => 0.17
2017-12-09 11:55 Kunda1 Note Edited: 0010549 View Revisions
2017-12-10 17:19 wmayer Summary STL object doesn't retain it's rotation after change => STL object doesn't retain its rotation after change
2017-12-12 20:47 wmayer Status confirmed => closed
2017-12-12 20:47 wmayer Resolution open => fixed
2017-12-12 20:47 wmayer Fixed in Version => 0.17
2017-12-12 20:47 wmayer Note Added: 0010593