View Issue Details

IDProjectCategoryView StatusLast Update
0003280FreeCADBugpublic2017-11-30 16:40
ReportereivindkvedalenAssigned Toeivindkvedalen 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version0.16 
Target Version0.17Fixed in Version0.17 
Summary0003280: Labels changing on save/restore - and expressions
DescriptionIn certain cases, the document is not correctly restored to its original state when loaded.

This can happen if labels are required to be unique; if there's no such requirement, the document is restored correctly. The problems is caused by the internal rename mechanism to enforce unique names. This kicks in during restore, and alters the labels incorrectly in certain cases.
Steps To ReproduceSee https://forum.freecadweb.org/viewtopic.php?f=10&t=24839
Tagsexpressions

Activities

wmayer

2017-11-30 16:40

administrator   ~0010503

https://github.com/FreeCAD/FreeCAD/commit/3b82ffff0229ff923b59601ddf643d2f7febb851

Issue History

Date Modified Username Field Change
2017-11-29 19:26 eivindkvedalen New Issue
2017-11-29 19:26 eivindkvedalen Status new => assigned
2017-11-29 19:26 eivindkvedalen Assigned To => eivindkvedalen
2017-11-29 20:00 Kunda1 Tag Attached: expressions
2017-11-30 16:40 wmayer Status assigned => closed
2017-11-30 16:40 wmayer Resolution open => fixed
2017-11-30 16:40 wmayer Fixed in Version => 0.17
2017-11-30 16:40 wmayer Note Added: 0010503