View Issue Details

IDProjectCategoryView StatusLast Update
0003189PartDesignBugpublic2017-09-21 11:35
ReporterickbyAssigned Toickby 
PrioritynormalSeveritymajorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version0.17 
Target Version0.17Fixed in Version0.17 
Summary0003189: Recompute fails after delete of object
Descriptionsee for file https://forum.freecadweb.org/viewtopic.php?f=10&t=24439

Run into this error once I delete Pocket003 in the attached file.

Funny thing is, if I save the file (once Pocket003 is deleted) and load it again, the error is gone. Also, if I delete Contour first and then Pocket003, the error doesn't occur to begin with.
TagsNo tags attached.

Activities

ickby

2017-09-16 08:14

developer   ~0010131

The issue is that Path Pocket003 has links to Body Pocket002. This means Path Pocket003 is in the inlist of Body Pocket002. Hence on remove it must be removed from the inlist on delete. Now when opening the file, there are 12 objects in the inlist of Body Pocket002, 10 times the PAth Pocket003. After deleting, there are 7 object in InList of Body Pocket002, and still 5 times Path Pocket003. Hence it seems that some links have not been correctly broken up on delete.

ickby

2017-09-16 10:15

developer   ~0010132

The problem in the file is the property link type change in Path Pocket. The Global version was added and the normal one deleted. However, property removal does not correctly maintain backlinks.

wmayer

2017-09-21 11:35

administrator   ~0010146

https://github.com/FreeCAD/FreeCAD/commit/00e7c0f2cb2cfb51acbbf75a5117050f79df062d

Issue History

Date Modified Username Field Change
2017-09-16 08:14 ickby New Issue
2017-09-16 08:14 ickby Status new => assigned
2017-09-16 08:14 ickby Assigned To => ickby
2017-09-16 08:14 ickby Note Added: 0010131
2017-09-16 10:15 ickby Note Added: 0010132
2017-09-21 11:35 wmayer Status assigned => closed
2017-09-21 11:35 wmayer Resolution open => fixed
2017-09-21 11:35 wmayer Fixed in Version => 0.17
2017-09-21 11:35 wmayer Note Added: 0010146