View Issue Details

IDProjectCategoryView StatusLast Update
0003184PartDesignBugpublic2017-09-21 09:11
ReporterickbyAssigned Toickby 
PriorityhighSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version0.17 
Target Version0.17Fixed in Version0.17 
Summary0003184: PDN boolean fails to display result
DescriptionWhen a PDN boolean is created and a PArt Feature added to it, the operation seems to work. However, no result is shown in the 3D view.
Steps To Reproduce1.Create Part::Box
2.Move box by (5,5,5)
3.Create Body
4.Create Box Primitive
5.Select Part::Box
6.Add PD Boolean operation

there should be a visible shape on the screen
TagsNo tags attached.

Activities

ickby

2017-09-15 17:34

developer   ~0010128

The problem is the display mode. By default it uses the ViewProviderGeoFeatureGroups "Group" display mode, which shows the childs. It must be changed automatically to the body display mode.
Note: check for all features if the body display mode is used by default, and make it universal if not

wmayer

2017-09-21 09:11

administrator   ~0010141

https://github.com/FreeCAD/FreeCAD/commit/f1c307dc282df41300a3d05a11884826474275d6

Issue History

Date Modified Username Field Change
2017-09-15 17:15 ickby New Issue
2017-09-15 17:15 ickby Status new => assigned
2017-09-15 17:15 ickby Assigned To => ickby
2017-09-15 17:34 ickby Note Added: 0010128
2017-09-21 09:11 wmayer Status assigned => closed
2017-09-21 09:11 wmayer Resolution open => fixed
2017-09-21 09:11 wmayer Fixed in Version => 0.17
2017-09-21 09:11 wmayer Note Added: 0010141