View Issue Details

IDProjectCategoryView StatusLast Update
0003179PartDesign[All Projects] Generalpublic2017-09-29 17:58
Reportergalou_breizhAssigned Towmayer 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.17 
Target VersionFixed in Version0.17 
Summary0003179: PDN + AdditiveBox + MultiTransform (with LinearPattern)
DescriptionYou cannot choose the direction of a LinearPattern within a MultiTransform.
Described in https://forum.freecadweb.org/viewtopic.php?f=19&t=23924.
Steps To ReproduceSteps to reproduce:
- Make a sketch
- Pad it
- Make an Additive Box, named "Box"
- Make a MultiTransform from "Box"
- Right-click to add a LinearPattern
- Notice that you cannot select any Direction for the LinearPattern.

If you do a LinearPattern directly instead of the MultiTransform, every works as it should. MirrorTransform inside MultiTransform also works.
Additional InformationOS: Ubuntu 14.04.5 LTS
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.17.11792 (Git)
Build type: None
Branch: master
Hash: 7aec98ffb66065854a66d6d6715845fdbf0869a7
Python version: 2.7.6
Qt version: 4.8.6
Coin version: 4.0.0a
OCC version: 7.1.0
Locale: English/UnitedStates (en_US)
TagsNo tags attached.

Activities

galou_breizh

2017-09-08 10:36

reporter  

bug_multitransform.fcstd (11,426 bytes)

Kunda1

2017-09-08 12:10

manager   ~0010091

Moved to 'PartDesign'

Kunda1

2017-09-15 23:57

manager   ~0010130

Fix proposed in p:FreeCAD:989:

normandc

2017-09-17 16:50

manager   ~0010135

Fix merged in commit #[url=https://github.com/FreeCAD/FreeCAD/pull/989/commits/2e2c041885dd6659c037e9b5ec90e4959615d215]2e2c041[/url]

galou_breizh

2017-09-27 08:11

reporter   ~0010199

This is strange. I use a FreeCAD version posterior to the merge of commit #2e2c041 and the problem is not solved.

OS: Ubuntu 14.04.5 LTS
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.17.12208 (Git)
Build type: None
Branch: master
Hash: 47cd41f25c1be55eabfe382f4a994d4b62eb8b0f
Python version: 2.7.6
Qt version: 4.8.6
Coin version: 4.0.0a
OCC version: 7.1.0
Locale: English/UnitedStates (en_US)

wmayer

2017-09-29 17:58

administrator   ~0010215

Fixed in commit #[url=https://github.com/FreeCAD/FreeCAD/commit/7ae850d75610439aba2ccdafccb6625faeabe351]7ae850d[/url]

Issue History

Date Modified Username Field Change
2017-09-08 10:36 galou_breizh New Issue
2017-09-08 10:36 galou_breizh File Added: bug_multitransform.fcstd
2017-09-08 12:09 Kunda1 Project File formats => PartDesign
2017-09-08 12:10 Kunda1 Product Version => 0.17
2017-09-08 12:10 Kunda1 Note Added: 0010091
2017-09-15 23:57 Kunda1 Note Added: 0010130
2017-09-17 16:50 normandc Note Added: 0010135
2017-09-27 08:11 galou_breizh Note Added: 0010199
2017-09-29 17:58 wmayer Assigned To => wmayer
2017-09-29 17:58 wmayer Status new => closed
2017-09-29 17:58 wmayer Resolution open => fixed
2017-09-29 17:58 wmayer Fixed in Version => 0.17
2017-09-29 17:58 wmayer Note Added: 0010215