View Issue Details

IDProjectCategoryView StatusLast Update
0003132PartDesignBugpublic2017-08-21 13:43
ReporterSamAssigned Towmayer 
PriorityhighSeveritycrashReproducibilityalways
Status closedResolutionfixed 
Platformintel i7 laptopOSubuntuOS Version16.04.2 LTS
Product Version0.17 
Target Version0.17Fixed in Version0.17 
Summary0003132: Bug? Crash when moving sketch to different body
Descriptionhttps://forum.freecadweb.org/viewtopic.php?f=3&t=23499&sid=27f35f9d0146676940fb0deb1aa91313#p183110

Reproducible crash
Steps To ReproduceI attach a drawing that causes FreeCAD to crash on me.

Within there is a sketch named "move me". It is a copy of Pc Board.

In Part Design I right click and "Move object to other body"

Whatever I choose, when I click OK it borks FreeCAD
Additional InformationOS: Ubuntu 16.04.2 LTS
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.17.11616 (Git)
Build type: None
Branch: master
Hash: aba4338808178b508f3170237f205e0066a5b437
Python version: 2.7.12
Qt version: 4.8.7
Coin version: 4.0.0a
OCC version: 7.1.0
Locale: English/UnitedKingdom (en_GB)
TagsNo tags attached.

Activities

Sam

2017-07-20 11:11

reporter  

1x x-end-motor-remade.fcstd (510,638 bytes)

Kunda1

2017-07-20 12:51

manager   ~0009787

@peterl94 can confirm with:

OS: Mac OS X
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.17.11616 (Git)
Build type: Release
Branch: master
Hash: aba4338808178b508f3170237f205e0066a5b437
Python version: 2.7.13
Qt version: 5.6.2
Coin version: 4.0.0a
OCC version: 7.1.0
Locale: English/UnitedStates (en_US)

[quote=peterl94]I imagine it is caused by the sketch not being in any body to begin with. To avoid the bug, you can drag the sketch into the body you want.[/quote]

wmayer

2017-08-21 13:43

administrator   ~0009980

This crash only occurred with sketches that do not belong to a body. There is a method to obtain the body of a sketch which in this case becomes a null pointer which isn't checked.

It's fixed now with: https://github.com/FreeCAD/FreeCAD/commit/7fbc80c11ecf783ead61be2294f23fa4dae9e8ca

Issue History

Date Modified Username Field Change
2017-07-20 11:11 Sam New Issue
2017-07-20 11:11 Sam File Added: 1x x-end-motor-remade.fcstd
2017-07-20 12:51 Kunda1 Status new => confirmed
2017-07-20 12:51 Kunda1 Note Added: 0009787
2017-07-20 12:54 Kunda1 OS Version latest => 16.04.02 LTS
2017-07-20 12:54 Kunda1 OS Version 16.04.02 LTS => 16.04.2 LTS
2017-07-20 12:55 Kunda1 Priority normal => high
2017-07-20 12:56 Kunda1 Target Version => 0.17
2017-08-21 13:43 wmayer Assigned To => wmayer
2017-08-21 13:43 wmayer Status confirmed => closed
2017-08-21 13:43 wmayer Resolution open => fixed
2017-08-21 13:43 wmayer Fixed in Version => 0.17
2017-08-21 13:43 wmayer Note Added: 0009980