View Issue Details

IDProjectCategoryView StatusLast Update
0000299FreeCADBugpublic2011-03-09 10:17
ReporterunauthenticatedAssigned Towmayer 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.11 
Target Version0.11Fixed in Version0.11 
Summary0000299: bottom face invisible
Descriptionpart design-> create a box->select a face (still in top view)-> create Sketch-> draw box -> Pad -> go to bottom view
 -> one can't see/select the bottom face

FreeCAD_0.11.4193_x86_RC_bin.7z
TagsNo tags attached.

Activities

2011-03-05 09:55

 

views.png (Attachment missing)

wmayer

2011-03-07 09:10

administrator   ~0000699

The problem is that the camera position is inside the object and thus it doesn't show faces behind it, switch to perspective mode and you'll see quite well. Doing a fit all makes the camera to jump out of the object.

So, the question is how to make sure that the camera doesn't suddenly lie into a newly created object that is quite big.

pperisin

2011-03-07 14:37

reporter   ~0000700

Yes, I have noticed quite some times that camera cuts objects, and shows inside of them.

Have no idea why?

Regards
Petar Perisin

wmayer

2011-03-09 09:00

administrator   ~0000712

This simply happens when an object changes its dimensions and then swallows the camera. I think we can implement a function that checks whether the camera suddenly lies in the global bounding box and then for orthographic camera increase the distance accordingly. The user won't realize this change because it has no zooming effect. For perspective camera we do simply nothing because otherwise it has a zooming effect and in case the camera lies inside an object the user will see this anyway.

wmayer

2011-03-09 10:17

administrator   ~0000713

A new method Command::adjustCameraPosition() is implemented which adjusts the clipping planes and the camera position without a zoom effect (orthographic mode only). So, this method can be used in commands which the above scenario can happen but a "view all" fit is not wanted.

I applied it on the pad command and it works fine.

Done in rev. 4214 & 4215.

Issue History

Date Modified Username Field Change
2011-03-05 09:55 unauthenticated New Issue
2011-03-05 09:55 unauthenticated File Added: views.png
2011-03-06 14:11 wmayer Resolution open => unable to reproduce
2011-03-07 09:10 wmayer Note Added: 0000699
2011-03-07 09:10 wmayer Status new => confirmed
2011-03-07 09:10 wmayer Resolution unable to reproduce => open
2011-03-07 09:16 wmayer Status confirmed => assigned
2011-03-07 09:16 wmayer Assigned To => wmayer
2011-03-07 14:37 pperisin Note Added: 0000700
2011-03-09 09:00 wmayer Note Added: 0000712
2011-03-09 10:17 wmayer Note Added: 0000713
2011-03-09 10:17 wmayer Status assigned => closed
2011-03-09 10:17 wmayer Resolution open => fixed
2011-03-09 10:17 wmayer Fixed in Version => 0.11
2011-03-09 10:17 wmayer Target Version => 0.11