View Issue Details

IDProjectCategoryView StatusLast Update
0002987FreeCADFeaturepublic2018-02-12 21:33
ReporterKunda1Assigned Towmayer 
PrioritynormalSeveritytweakReproducibilityhave not tried
Status closedResolutionfixed 
Product Version0.17 
Target Version0.17Fixed in Version0.17 
Summary0002987: FreeCAD should recognize when it's been built as an appimage
DescriptionCurrently running AppImage on Manjaro 17.0
[code=text]OS: "Manjaro Linux"
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.17.10600 (Git)
Build type: None
Branch: master
Hash: 4d9169faf778e9716fc647fb3fcf46462b5d99a4
Python version: 2.7.6
Qt version: 4.8.6
Coin version: 4.0.0a
OCC version: 7.1.0[/code]

IMO [s][b]Built type:[/b] should say '[b]AppImage[/b]' instead of 'None'[/s] (this is reserved for 'stable' and 'debug' builds. So then possibly appending [i]AppImage[/i] to the [b]Version:[/b] field ?

Could look like this:
[code=text]OS: "Manjaro Linux"
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
[color=red]Version:[/color] 0.17.10600 (Git) [color=red]AppImage[/color]
Build type: None
Branch: master
Hash: 4d9169faf778e9716fc647fb3fcf46462b5d99a4
Python version: 2.7.6
Qt version: 4.8.6
Coin version: 4.0.0a
OCC version: 7.1.0[/code]
Additional InformationForum thread: https://forum.freecadweb.org/viewtopic.php?f=10&t=15525&p=167511#p167511
AppImage ticket: https://github.com/AppImage/AppImageKit/issues/429
https://github.com/FreeCAD/FreeCAD-AppImage/issues/2
Tagsappimage, packaging

Activities

Kunda1

2017-03-27 19:49

manager   ~0008720

Last edited: 2017-03-27 20:56

View 3 revisions

Looks like somewhere in the appimage configuration [s]it needs to set the CMake flag ${CMAKE_BUILD_TYPE} to 'appimage'. Just an educated guess.[/s] there needs to be a way to indicate a new variable to be shown.

Kunda1

2017-03-27 20:11

manager   ~0008721

@triplus do you mind weighing in on this?

Kunda1

2018-02-09 20:42

manager   ~0010938

This would be great to have before the 0.17 release.

wmayer

2018-02-12 18:42

administrator   ~0010947

What is the output of this when FreeCAD is built as AppImage?
[code=Python]
import os
os.environ["APPIMAGE"]
[/code]

Kunda1

2018-02-12 20:34

manager   ~0010951

When I run that code snippet in the console I get:
[code=python]
>>> import os
>>> os.environ["APPIMAGE"]
'/home/foo/Downloads/FreeCAD_0.17.13247.glibc2.17-x86_64.AppImage'
[/code]

wmayer

2018-02-12 20:56

administrator   ~0010953

Thanks! All what I wanted to know is that the env. variable APPIMAGE is really set. Its actual value is irrelevant.

wmayer

2018-02-12 21:23

administrator   ~0010954

https://github.com/FreeCAD/FreeCAD/commit/88e8c98d345c31f7c16711cb1702e10fba21f6c1

Issue History

Date Modified Username Field Change
2017-03-27 19:42 Kunda1 New Issue
2017-03-27 19:42 Kunda1 Tag Attached: appimage
2017-03-27 19:43 Kunda1 Description Updated View Revisions
2017-03-27 19:49 Kunda1 Note Added: 0008720
2017-03-27 20:11 Kunda1 Note Added: 0008721
2017-03-27 20:11 Kunda1 Additional Information Updated View Revisions
2017-03-27 20:55 Kunda1 Note Edited: 0008720 View Revisions
2017-03-27 20:56 Kunda1 Note Edited: 0008720 View Revisions
2017-07-13 11:42 Kunda1 Additional Information Updated View Revisions
2017-07-13 13:14 Kunda1 Description Updated View Revisions
2017-07-13 13:16 Kunda1 Description Updated View Revisions
2017-07-13 13:16 Kunda1 Description Updated View Revisions
2018-02-09 20:21 Kunda1 Tag Attached: packaging
2018-02-09 20:42 Kunda1 Target Version => 0.17
2018-02-09 20:42 Kunda1 Note Added: 0010938
2018-02-12 18:42 wmayer Note Added: 0010947
2018-02-12 20:34 Kunda1 Note Added: 0010951
2018-02-12 20:56 wmayer Note Added: 0010953
2018-02-12 21:23 wmayer Assigned To => wmayer
2018-02-12 21:23 wmayer Status new => closed
2018-02-12 21:23 wmayer Resolution open => fixed
2018-02-12 21:23 wmayer Fixed in Version => 0.17
2018-02-12 21:23 wmayer Note Added: 0010954
2018-02-12 21:33 Kunda1 Additional Information Updated View Revisions