View Issue Details

IDProjectCategoryView StatusLast Update
0002952FreeCADBugpublic2017-03-27 17:25
ReporterblaceyAssigned To 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version0.17 
Target Version0.17Fixed in Version0.17 
Summary0002952: Save Image... results in all-black image file when FreeCAD is built with Qt 5
DescriptionThe Save Image... feature creates a totally black image file when using Qt 5. This issue occurs on both Linux and macOS.
TagsQt5

Relationships

child of 0002986 confirmed Port from Qt4 to Qt5 (Ongoing) 

Activities

wmayer

2017-03-08 11:44

administrator   ~0008574

This seems a regression of Qt5 compared to Qt4. It looks like pixel buffer support has been completely dropped (even for the deprecated QtOpenGL module and internally FBO is used). So, either add the key "DisablePBuffers" or "CoinOffscreenRenderer" and set it to true (under BaseApp/Preferences/Document).

With the real pixel buffer under Qt4 we had the best results because anti-aliasing was supported and transparencies worked quite well, too. Now with Qt5 we can use FBO which also supports anti-aliasing but totally fails for transparencies or use the old built-in Coin offscreen renderer that supports transparencies but no anti-aliasing.

Issue History

Date Modified Username Field Change
2017-03-07 03:34 blacey New Issue
2017-03-07 12:34 Kunda1 Tag Attached: Qt5
2017-03-08 11:44 wmayer Note Added: 0008574
2017-03-21 19:44 wmayer Changeset attached => FreeCAD master c193dbe2
2017-03-21 19:46 wmayer Changeset attached => FreeCAD master 5bf326c1
2017-03-21 19:49 wmayer Status new => closed
2017-03-21 19:49 wmayer Resolution open => fixed
2017-03-21 19:49 wmayer Fixed in Version => 0.17
2017-03-27 17:25 Kunda1 Relationship added child of 0002986