View Issue Details

IDProjectCategoryView StatusLast Update
0000295FreeCADBugpublic2011-03-08 19:37
ReporterpperisinAssigned ToJriegel 
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionfixed 
Product Version0.11 
Target Version0.11Fixed in Version0.12 
Summary0000295: STEP AP214 export crashes FreeCAD on win7
DescriptionHi,

I have tested this function on couple of winxp, one ubuntu and 3 win7 computers.
Ubuntu and xp stuff went ok - FreeCAD exported STEP AP214 successfully.

But on all three installations on win7, FreeCAD Crashes when trying to export simple cube with random color to STEP AP214

Regards
Petar Perisin
Additional InformationCrashes on one comp with
win7 32bit
and two comps with
win7 64bit
TagsNo tags attached.

Activities

Jriegel

2011-03-02 16:37

administrator   ~0000676

I can confirm the crash...

Jriegel

2011-03-02 19:49

administrator   ~0000677

in AppImportGuiPy.cpp line 170 OpenCasCade totaly screw the heap. Its
not cachable by exception.

Did it somtimes work?

unauthenticated

2011-03-03 07:30

viewer   ~0000678

nope. It would always crash on win7

never got it to work.

but, while we (I mean Werner) were developing this stuff, first we were using script that was using pythonOCC. Script is here on third page -> last werner's post.
http://forum.freecadweb.org/viewtopic.php?f=8&t=516&start=20
Script would translate parts using __toPythonOCC__, and everithing else was done using pythonOCC (except during export FreeCAD was used to get color info from all parts). Using this script worked, but after Werner implemented it using C++, and without pythonOCC, it never worked.

Regards,
Petar Perisin

wmayer

2011-03-03 15:03

administrator   ~0000679

No crash here on Win7 64-bit. Maybe the package from SF has some OCC DLLs that use different C runtime DLLs.

wmayer

2011-03-03 16:07

administrator   ~0000680

Using the latest version from SF I see this crash, too.

However, the files TKXCAF.dll, TKXDEIGES.dll, TKXDESTEP.dll are wrong because they link to MSVCRT version 7 while other DLLs are using version 9. Mixing up runtime DLLs is a bad idea because it could lead to unexpected behaviour.

When replacing the above three files with the correctly built ones everything works.

wmayer

2011-03-03 16:09

administrator   ~0000681

It is up to you: just build the three files using VS 2008 and you're done.

Jriegel

2011-03-03 17:18

administrator   ~0000682

Mhh, thats seldome, I will check!

2011-03-04 07:47

 

XDE.zip (Attachment missing)

wmayer

2011-03-04 07:49

administrator   ~0000685

I have uploaded the updated files in the attached zip file. Please replace those of your FreeCAD installation with them.

unauthenticated

2011-03-04 14:57

viewer   ~0000690

Confirmed that it works after replacing files.

Regards,
Petar Perisin

pperisin

2011-03-04 17:36

reporter   ~0000691

Hi,

Just to inform that Release candidate from today does not have this update. I think LibPack should also be updated with this three files. But on my own builds, after switching files in LibPack, the function works.

Regards
Petar Perisin

Issue History

Date Modified Username Field Change
2011-03-02 09:37 pperisin New Issue
2011-03-02 16:37 Jriegel Note Added: 0000676
2011-03-02 16:37 Jriegel Status new => confirmed
2011-03-02 19:49 Jriegel Note Added: 0000677
2011-03-02 19:49 Jriegel Status confirmed => assigned
2011-03-02 19:49 Jriegel Assigned To => wmayer
2011-03-02 19:49 Jriegel Target Version => 0.11
2011-03-03 07:30 unauthenticated Note Added: 0000678
2011-03-03 15:03 wmayer Note Added: 0000679
2011-03-03 16:07 wmayer Note Added: 0000680
2011-03-03 16:09 wmayer Note Added: 0000681
2011-03-03 16:09 wmayer Assigned To wmayer => Jriegel
2011-03-03 17:18 Jriegel Note Added: 0000682
2011-03-04 07:47 wmayer File Added: XDE.zip
2011-03-04 07:49 wmayer Note Added: 0000685
2011-03-04 14:57 unauthenticated Note Added: 0000690
2011-03-04 17:36 pperisin Note Added: 0000691
2011-03-08 19:37 Jriegel Status assigned => closed
2011-03-08 19:37 Jriegel Resolution open => fixed
2011-03-08 19:37 Jriegel Fixed in Version => 0.12