View Issue Details

IDProjectCategoryView StatusLast Update
0000281FreeCADFeaturepublic2011-09-17 06:24
ReporterJriegelAssigned ToJriegel 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version 
Target Version0.12Fixed in Version0.12 
Summary0000281: Fix constraint
DescriptionAdd a constraint to the sketcher to fix a geometry to its position.
TagsNo tags attached.

Relationships

child of 0000278 closedJriegel Developing Sketcher 

Activities

Jriegel

2011-06-02 12:17

administrator   ~0000880

Logari has implemented two fix constraints for x and y seperate. Work
pretty well. But now the dragging of points has a problem. If dragged mostly
the sketch dont solve.

Dragging has to test different degrees of freedom. First try drag x,y and if
fail try x and y seperately. Starting with the widest distance.

logari81

2011-06-03 05:19

developer   ~0000881

I am working on this.

Jriegel

2011-06-04 12:10

administrator   ~0000882

Hi Logari,
how is it going? Working on the new Solver?

I have seen NaroCAD has also adopted the sketchsolve solver..

aforencich

2011-09-06 01:09

reporter   ~0001041

Is there an ETA on being able to create constraints between a sketch and features on the face it was created on? E.g. the abiliity to create a pocket on a face and constrain its position w.r.t the face that it's created on.

From playing around with FreeCAD, this seems to be the biggist glaring hole. If support for this is added, I might actually be able to use freecad for a few things.

logari81

2011-09-06 06:26

developer   ~0001042

external constraints are in our todo list but with voluntary work there is never an ETA. Btw. you are quite off topic here, please use the phpbb forum to ask about the progress of any feature.

unauthenticated

2011-09-06 06:41

viewer   ~0001043

Well, I *was* going to post a new bug report about not being able to do that until I saw this bug which I thought was somewhat similar. I suppose I will just make a new bug report in the future then.

Jriegel

2011-09-16 04:59

administrator   ~0001090

resolved with logaris xy constraint

wmayer

2011-09-17 06:24

administrator   ~0001100

Set to closed.

Issue History

Date Modified Username Field Change
2011-02-22 12:44 Jriegel New Issue
2011-02-22 12:44 Jriegel Assigned To => Jriegel
2011-02-22 12:44 Jriegel Status new => assigned
2011-02-22 12:44 Jriegel Target Version => 0.12
2011-02-22 12:45 Jriegel Relationship added child of 0000278
2011-02-22 12:51 Jriegel Relationship deleted child of 0000278
2011-02-22 12:51 Jriegel Relationship added child of 0000278
2011-06-02 12:17 Jriegel Note Added: 0000880
2011-06-03 05:19 logari81 Note Added: 0000881
2011-06-04 12:10 Jriegel Note Added: 0000882
2011-09-06 01:09 aforencich Note Added: 0001041
2011-09-06 06:26 logari81 Note Added: 0001042
2011-09-06 06:41 unauthenticated Note Added: 0001043
2011-09-16 04:59 Jriegel Note Added: 0001090
2011-09-16 04:59 Jriegel Status assigned => resolved
2011-09-16 04:59 Jriegel Resolution open => fixed
2011-09-16 05:02 Jriegel Fixed in Version => 0.12
2011-09-17 06:24 wmayer Note Added: 0001100
2011-09-17 06:24 wmayer Status resolved => closed