View Issue Details

IDProjectCategoryView StatusLast Update
0002801FreeCADBugpublic2016-12-18 09:51
ReporterkkremitzkiAssigned Towmayer 
PrioritylowSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformLinuxOSUbuntu & FedoraOS Version16.04 & 25
Product Version0.16 
Target Version0.17Fixed in Version0.17 
Summary0002801: F11 enters fullscreen, but does not exit (should behave as toggle)
DescriptionI tested this on my Ubuntu 16.04 dev machine running 0.17 and on a fresh install of Fedora 25 with Freecad 0.16 installed from the repositories. Create a new file. Pressing F11 enters fullscreen, but does not exit it as well. Right clicking and going to Document Window shows an option for "Fullscreen" mapped to F11, but clicking this does nothing. One must press Escape in order to leave.

Just to survey a few other applications I have as an example, Chrome, Firefox, and QGIS all use F11 for fullscreen, and pressing it again toggles fullscreen to go back to normal. LibreOffice uses CTRL+SHIFT+J for fullscreen, but pressing it again also toggles it.

This is a UX bug because it breaks user expectations about standard interaction. It's analogous to mapping "save to CTRL+V instead of CTRL+S; while technically something you may be able to do, best not.
Steps To ReproduceCreate new document.
Press F11.
Attempt to undo the view change by pressing the same button.
TagsNo tags attached.

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2016-12-01 08:07 kkremitzki New Issue
2016-12-18 09:50 wmayer Changeset attached => FreeCAD Master master 723cb4f3
2016-12-18 09:50 wmayer Assigned To => wmayer
2016-12-18 09:50 wmayer Status new => closed
2016-12-18 09:50 wmayer Resolution open => fixed
2016-12-18 09:51 wmayer Target Version => 0.17
2016-12-18 09:51 wmayer Fixed in Version => 0.17