View Issue Details

IDProjectCategoryView StatusLast Update
0002769FreeCADBugpublic2021-02-20 14:10
ReporterPatola Assigned Torealthunder  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionduplicate 
Product Version0.16 
Summary0002769: Recomputation breaks sketch
DescriptionI have the file ixora-final-revisada which works correctly when I change Case/Invólucro/Thickness/chao's Length and Width, but breaks when I change Height, indicating a problem in one of the sketches (saying "SketchBased: Up to face: No faces found in this direction"). I have attached screenshots of the problem

URL of file in google drive: https://drive.google.com/file/d/0B8WZj6JJHZDwc0FYMUZ5aWd6SG8/view?usp=sharing
Steps To Reproduce1 - open ixora-final-revisada (tried in FreeCAD 0.16 1:0.16.6703-1ppa1~ubuntu16.04.1 from freecad-stable PPA and freecad-daily 0.17 0.17~alpha1+git201611112327~ubuntu16.04.1 )
2 - go to element Case/Invólucro/Thickness/chao
3 - change Width of Length. It scales accordingly.
4 - change Height. It breaks and to no scale. This happens independent of Width or Length being also changed.
Additional InformationScreenshots uploaded to ToileLibre

1 - document open - http://pix.toile-libre.org/upload/original/1478969091.png (attached to ticket as 1478969091.png)
2 - length changed - http://pix.toile-libre.org/upload/original/1478969120.png (attached to ticket as 1478969120.png)
3 - height changed, with error message - http://pix.toile-libre.org/upload/original/1478969151.png (attached to ticket as 1478969151.png)
Tagstoponaming
FreeCAD Information

Relationships

duplicate of 0000922 assignedrealthunder Topological Naming 
has duplicate 0002768 closed Recomputation breaks sketch 

Activities

normandc

2016-11-15 01:26

manager   ~0007460

Without having looked at your file, this is almost certainly a topological naming issue. See 0000922

Patola

2016-11-15 04:55

reporter   ~0007461

Sorry, I am not sure what you mean. I have seen 0000922 and it points to a sourceforge wiki page which does not exist anymore. I googled and came up with this page: http://www.freecadweb.org/wiki/index.php?title=Naming_project but although it vaguely seems related, not knowing deeply about the entrails of FreeCAD I do not see what I can do to help diagnosing it and proceeding with the fix.

normandc

2016-11-20 21:34

manager   ~0007483

There is no diagnosing to do, the issue is well-known and well documented. If you search the forum for "topological naming", you will find tens if not hundreds of topics. It is an issue that is extremely difficult to solve, which is why it still persists 4 years after it was detected. One developer has recently tackled the problem but progress will be slow, it may take many more years and releases until it is fixed.

In the forum there are many topics where strategies to work around the issue are discussed. The new PartDesign workflow in 0.17 can do a lot for that. Therefore I feel that you should have posted on the forum first before reporting a bug here.

I have fixed the link in the 922 report, but berndhahnebach already gave it in the comments.

Patola

2016-11-21 09:41

reporter   ~0007484

Well, sorry then. I searched for it extensively on the forums and bugtracker before opening this issue, but as I did not know this is a long-known issue from "topological naming" I probably did not use the right terms. I also thought that just posting a file with a problem on the forum and asking people on how to fix this bug or address this issue is not a proper discussion, so I went to the bugtracker instead. So, shall I use the forum instead of the bugtracker every time I am not 100% aware about the issues related to or pertaining to the problem I report?

Kunda1

2017-01-14 13:09

administrator   ~0007761

Last edited: 2017-01-14 13:12

View 2 revisions

@Patola
> So, shall I use the forum instead of the bugtracker every time I am not 100% aware about the issues related to or pertaining to the problem I report?
From what I've read the idea is to: Search both the forum and the bugtracker. If you find a ticket on the tracker that doesn't lead to a forum thread then open a forum thread and link back to the ticket using for ex. [bug]7460[/bug] in the forum (long discussions on the tracker are discouraged, that's what the forum is for). If you don't find a ticket or a thread, then open a thread on the forum and link back to the ticket (as per above). Hope that makes sense.

Also, please post the forum thread you opened for this issue back in this ticket. Thanks!

Edit: also making this ticket a child of 0000922

Patola

2017-01-14 14:29

reporter   ~0007762

By now I understand topological naming much better and I am also trying to follow the "Resilient Modeling Strategy" from freecad forum suggestions. I also understand why it is not proper to open yet another entry about this broad range issue.

As for my problem, I worked around it, and I look forward to use 0.17 when it is a stable release; I am already learning by experimenting with the development version (freecad-daily). Thanks for the guidance. I also plan to educate others on this issue and I hope I can help developers focus on the issue instead of responding to multiple redundant issues. Should this issue be closed? Or will it remain open until 0000922 is closed?

Kunda1

2017-01-19 12:48

administrator  

1478969091.png (Attachment missing)

Kunda1

2017-01-19 12:50

administrator  

1478969120.png (Attachment missing)

Kunda1

2017-01-19 12:50

administrator  

1478969151.png (Attachment missing)

Kunda1

2017-02-15 04:40

administrator   ~0008301

Duplicate of 0000922

Issue History

Date Modified Username Field Change
2016-11-12 16:52 Patola New Issue
2016-11-12 18:30 wmayer Relationship added has duplicate 0002768
2016-11-15 01:26 normandc Note Added: 0007460
2016-11-15 04:55 Patola Note Added: 0007461
2016-11-20 21:34 normandc Note Added: 0007483
2016-11-21 09:41 Patola Note Added: 0007484
2017-01-14 13:09 Kunda1 Note Added: 0007761
2017-01-14 13:09 Kunda1 Status new => feedback
2017-01-14 13:12 Kunda1 Note Edited: 0007761 View Revisions
2017-01-14 13:12 Kunda1 Relationship added child of 0000922
2017-01-14 14:29 Patola Note Added: 0007762
2017-01-14 14:29 Patola Status feedback => new
2017-01-19 12:48 Kunda1 File Added: 1478969091.png
2017-01-19 12:50 Kunda1 File Added: 1478969120.png
2017-01-19 12:50 Kunda1 File Added: 1478969151.png
2017-01-19 12:50 Kunda1 Additional Information Updated View Revisions
2017-02-15 04:40 Kunda1 Note Added: 0008301
2017-02-15 04:40 Kunda1 Relationship replaced duplicate of 0000922
2017-02-15 04:40 Kunda1 Status new => resolved
2017-02-15 04:40 Kunda1 Resolution open => duplicate
2017-02-15 04:40 Kunda1 Assigned To => Kunda1
2017-02-15 04:40 Kunda1 Assigned To Kunda1 =>
2017-03-10 20:33 kkremitzki Assigned To => kkremitzki
2017-03-10 20:33 kkremitzki Status resolved => closed
2021-02-20 14:10 Kunda1 Assigned To kkremitzki => realthunder
2021-02-20 14:10 Kunda1 Tag Attached: toponaming