View Issue Details

IDProjectCategoryView StatusLast Update
0002758PartDesignBugpublic2018-07-12 03:47
ReporterPauvres_honteuxAssigned ToDeepSOIC 
PriorityhighSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Platformx86_64OSopenSUSE LeapOS Version42.1
Product Version0.17 
Target VersionFixed in Version0.17 
Summary0002758: Datum point moves to (0,0,0) when reopening the file.
DescriptionOS: "openSUSE Leap 42.1 (x86_64)"
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.17.8819 (Git) (Packman)
Build type: Release
Branch: master
Hash: 195ea429e696377980b4edbf4a4affdb1f46abaa
Python version: 2.7.12
Qt version: 4.8.6
Coin version: 4.0.0a
OCC version: 6.9.1.oce-0.18-dev

When reopening a file containing a DatumPoint, that DatumPoint has moved to (0,0,0) from its original position.
Steps To ReproduceCreate a new document.
Choose PartDesign workbench.
Create a new Part and make it active.
Create a new Body and make it active.
In the Body, create a new DatumPoint and choose Attachment mode: "Object's origin", click OK.
In DatumPoint's Data-tab, set X=5, Y=10, Z=15.
Save the file with a name.
Close the program.
Open the program and the named file.
In Data-tab, read the values for the DatumPoint. It is now (0,0,0).
Additional InformationAttaching a DatumPlane and/or a sketch to that DatumPoint will result in a linkage loss at save/open.
Though it seams as if the DatumPlane and/or sketch has created a copy of the DatumPoint position, i.e. anything connected to the DatumPlane and/or sketch is still intact after reopening the file. Moving the DatumPoint will not result in any position changes of the DatumPlane and/or sketch.
Tagslines, Part Design, Placement, planes, points

Activities

Pauvres_honteux

2016-11-05 12:46

reporter   ~0007442

Related discussion:
http://forum.freecadweb.org/viewtopic.php?f=8&t=17630&start=10

Pauvres_honteux

2018-01-21 12:15

reporter   ~0010804

More information in this issue in attached PDF.

Point_Line_Plane_Sketch_Pad.pdf (1,192,808 bytes)

wmayer

2018-04-04 15:55

administrator   ~0011123

https://github.com/FreeCAD/FreeCAD/commit/d2ee3d2ac09bf1c1f32f42e8a971d27c601d9e4a

DeepSOIC

2018-04-11 15:08

developer   ~0011140

Last edited: 2018-04-11 15:09

View 2 revisions

Reopening, because my fix was incomplete. Datum point shape is restored after Datum::Point::Restore is finished, so recreation of shape does not do what it was supposed to.

DeepSOIC

2018-05-13 16:34

developer   ~0011248

fixed by https://github.com/FreeCAD/FreeCAD/commit/8a7525f620db88dbd8082b44641f5d905e6c43bb

Kunda1

2018-05-21 10:07

manager   ~0011266

@DeepSOIC can this ticket be closed ?

Kunda1

2018-06-10 22:11

manager   ~0011399

@DeepSOIC ping

Kunda1

2018-07-12 03:47

manager   ~0011513

Closing

Issue History

Date Modified Username Field Change
2016-11-05 12:36 Pauvres_honteux New Issue
2016-11-05 12:39 Pauvres_honteux Tag Attached: Part Design
2016-11-05 12:39 Pauvres_honteux Tag Attached: Placement
2016-11-05 12:39 Pauvres_honteux Tag Attached: planes
2016-11-05 12:39 Pauvres_honteux Tag Attached: points
2016-11-05 12:46 Pauvres_honteux Note Added: 0007442
2016-11-29 14:18 ickby Assigned To => ickby
2016-11-29 14:18 ickby Status new => assigned
2018-01-21 12:13 Pauvres_honteux Tag Attached: lines
2018-01-21 12:15 Pauvres_honteux File Added: Point_Line_Plane_Sketch_Pad.pdf
2018-01-21 12:15 Pauvres_honteux Note Added: 0010804
2018-04-04 15:55 wmayer Assigned To ickby => DeepSOIC
2018-04-04 15:55 wmayer Status assigned => closed
2018-04-04 15:55 wmayer Resolution open => fixed
2018-04-04 15:55 wmayer Fixed in Version => 0.17
2018-04-04 15:55 wmayer Note Added: 0011123
2018-04-11 15:07 DeepSOIC Status closed => feedback
2018-04-11 15:07 DeepSOIC Resolution fixed => reopened
2018-04-11 15:08 DeepSOIC Note Added: 0011140
2018-04-11 15:09 DeepSOIC Note Edited: 0011140 View Revisions
2018-05-13 16:34 DeepSOIC Note Added: 0011248
2018-05-13 16:36 DeepSOIC Status feedback => resolved
2018-05-13 16:36 DeepSOIC Resolution reopened => fixed
2018-05-21 10:07 Kunda1 Note Added: 0011266
2018-06-10 22:11 Kunda1 Note Added: 0011399
2018-07-12 03:47 Kunda1 Status resolved => closed
2018-07-12 03:47 Kunda1 Note Added: 0011513