View Issue Details

IDProjectCategoryView StatusLast Update
0002741PartDesignBugpublic2017-07-11 20:06
Reporterdumr666Assigned To 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
PlatformLinuxOSMint XFCEOS Version18
Product Version0.17 
Target Version0.17Fixed in Version0.17 
Summary0002741: Crashes when drawing tutorial
DescriptionFreeCAD crashes everytime when I draw two squares for extrusion of side "wings" in the tutorial here
http://www.freecadweb.org/wiki/index.php?title=Basic_Part_Design_Tutorial

I attached picture, crash happens every single time when I click close
Steps To ReproduceFollow drawing tutorial shape, and then will see what happens
TagsNo tags attached.

Activities

dumr666

2016-10-18 20:11

reporter  

Kunda1

2017-01-13 13:17

manager   ~0007712

@dumr666 please post:
1) your system specs via Help > About Freecad
2) if possible, a backtrace of the crash (http://www.freecadweb.org/wiki/index.php?title=Debugging)

Kunda1

2017-01-22 14:57

manager   ~0007913

Forum thread: https://forum.freecadweb.org/viewtopic.php?f=10&t=20123

nemesis

2017-01-22 20:45

reporter   ~0007915

Tested on
OS: Mac OS X
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.17.9692 (Git)
Build type: Release
Branch: (detached from 2a67c7f)
Hash: 2a67c7f0ae2f600d10874feba90f74ab66c34a16
Python version: 2.7.13
Qt version: 4.8.7
Coin version: 3.1.3
OCC version: 7.0.0

no issue for me.

nemesis

2017-01-22 20:46

reporter  

tuto.FCStd (54,150 bytes)

Kunda1

2017-01-27 03:36

manager   ~0008016

Testers are unable to reproduce bug. (see above and https://forum.freecadweb.org/viewtopic.php?p=156247#p156247)
Resolving as fixed in 0.17

wmayer

2017-01-31 18:22

administrator   ~0008133

Very likely this has been fixed in the meantime.

wmayer

2017-02-01 09:32

administrator   ~0008143

See also: https://forum.freecadweb.org/viewtopic.php?f=19&t=20407&p=157450#p157450

wmayer

2017-02-27 08:04

administrator   ~0008464

Issue has been resolved somehow. Nevertheless, the mentioned line in https://forum.freecadweb.org/viewtopic.php?f=19&t=20407&start=20#p160789 has been removed since it's superfluous.

Issue History

Date Modified Username Field Change
2016-10-18 20:11 dumr666 New Issue
2016-10-18 20:11 dumr666 File Added: Screenshot_2016-10-18_22-05-24.png
2017-01-13 13:17 Kunda1 Note Added: 0007712
2017-01-13 13:17 Kunda1 Status new => feedback
2017-01-22 14:57 Kunda1 Note Added: 0007913
2017-01-22 14:57 Kunda1 Tag Attached: #pending
2017-01-22 20:45 nemesis Note Added: 0007915
2017-01-22 20:46 nemesis File Added: tuto.FCStd
2017-01-27 03:36 Kunda1 Note Added: 0008016
2017-01-27 03:36 Kunda1 Status feedback => resolved
2017-01-27 03:36 Kunda1 Fixed in Version => 0.17
2017-01-27 03:36 Kunda1 Resolution open => fixed
2017-01-27 03:36 Kunda1 Assigned To => Kunda1
2017-01-27 03:36 Kunda1 Assigned To Kunda1 =>
2017-01-31 18:22 wmayer Note Added: 0008133
2017-01-31 18:22 wmayer Status resolved => closed
2017-02-01 09:32 wmayer Note Added: 0008143
2017-02-01 09:33 wmayer Status closed => feedback
2017-02-01 09:33 wmayer Resolution fixed => reopened
2017-02-15 05:51 kkremitzki Target Version => 0.17
2017-02-27 08:02 wmayer Changeset attached => FreeCAD master 441ce4a1
2017-02-27 08:04 wmayer Status feedback => closed
2017-02-27 08:04 wmayer Resolution reopened => fixed
2017-02-27 08:04 wmayer Note Added: 0008464
2017-07-11 20:06 Kunda1 Tag Detached: #pending