View Issue Details

IDProjectCategoryView StatusLast Update
0000271FreeCADBugpublic2011-03-01 10:44
ReporternormandcAssigned Towmayer 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version0.11 
Target Version0.11Fixed in Version0.11 
Summary0000271: Edge selection in Gui model window doesn't work anymore
DescriptionIn Part workbench, for Fillet and Chamfer tools, the selection of edges directly on the 3D model doesn't work anymore. On the Tasks tab, no edge gets "ticked" in the list, and if the OK button is pressed, an error message about no edge having been selected pops up.

Precise svn number for which this bug appeared is unclear. But I've been building Debian packages instead of compiling, and kept all of them, I reinstalled a few to check:

from trunk
r4030: edge selection working fine
r4075: not working

from /branches/V-0-11
r4073: not working

Since the bug affects the 0.11 branch, I'm setting this bug as major.
Additional InformationFreeCAD 0.11.40XX on Ubuntu 10.04 LTS
TagsNo tags attached.

Activities

normandc

2011-02-19 12:54

manager   ~0000622

Forgot to specify that my OS is 64-bit.

normandc

2011-02-20 14:45

manager   ~0000623

Last edited: 2011-02-20 14:45

Some more info on this bug. It seems to affect certain languages.

English and German are fine, but other languages show the same bug, here are the ones tested with the same bug:

French
Spanish
Italian
Norwegian
Portugese
Russian

For info, my Ubuntu 10.04.1 LTS 64-bit system's locale is French.

wmayer

2011-02-20 15:51

administrator   ~0000624

To reproduce this look at:
http://forum.freecadweb.org/viewtopic.php?f=3&t=831&p=6130#p6130

wmayer

2011-02-22 22:33

administrator   ~0000630

Today I tried it again to check why it happens. But I cannot reproduce this behaviour anymore. Now it seems to always work.

normandc

2011-02-23 02:39

manager   ~0000634

Downloaded and installed r4119. The bug still persists on my end.

normandc

2011-02-26 14:45

manager   ~0000649

More info: as discussed in the forum, the problem affects two different hardware configurations, both on Ubuntu 10.04 LTS 64-bit with FreeCAD installed from a debian package built from trunk r4139.

- desktop AMD Athlon64 X2 6000+ Nvidia GeForce 9800GT with 195.36.24 drivers
- laptop Intel Core2 Solo SU3500 with Intel GMA 4500MHD graphics with open source drivers

I will try to check if the problem happens on a regular compile, and on a different Ubuntu version.

wmayer

2011-03-01 10:44

administrator   ~0000671

Fixed in rev. 4168/4169

Issue History

Date Modified Username Field Change
2011-02-18 23:52 normandc New Issue
2011-02-19 12:54 normandc Note Added: 0000622
2011-02-20 14:45 normandc Note Added: 0000623
2011-02-20 14:45 normandc Note Edited: 0000623
2011-02-20 15:51 wmayer Note Added: 0000624
2011-02-20 15:53 wmayer Assigned To => wmayer
2011-02-20 15:53 wmayer Status new => confirmed
2011-02-20 15:53 wmayer Target Version => 0.11
2011-02-22 22:33 wmayer Note Added: 0000630
2011-02-23 02:39 normandc Note Added: 0000634
2011-02-26 14:45 normandc Note Added: 0000649
2011-03-01 10:44 wmayer Note Added: 0000671
2011-03-01 10:44 wmayer Status confirmed => closed
2011-03-01 10:44 wmayer Resolution open => fixed
2011-03-01 10:44 wmayer Fixed in Version => 0.11