View Issue Details

IDProjectCategoryView StatusLast Update
0000270DraftFeaturepublic2014-01-01 16:01
ReporterunauthenticatedAssigned Toyorik 
PrioritylowSeverityminorReproducibilityhave not tried
Status closedResolutionreopened 
Product Version 
Target Version0.13Fixed in Version0.13 
Summary0000270: Make the Draft offset function working on b-splines
DescriptionMaking the offset function working for B-Spline would be nice.
TagsNo tags attached.

Activities

unauthenticated

2011-02-17 21:14

viewer   ~0000617

Sure it would! I'll take this but might take a bit of time to do it.

unauthenticated

2011-02-18 07:12

viewer   ~0000620

No problem take your time!

yorik

2011-10-17 17:43

administrator   ~0001174

Actually this is pretty hard to do, one needs to calculate perpendicular to bspline edges, and I have no idea about how to do it... I'll leave this for post-0.12 release...

mrlukeparry

2011-10-22 06:56

developer   ~0001183

this might be helpful:
http://wiki.inkscape.org/wiki/index.php/SpecFilletChamfer

we might eventually implement this into sketcher a long time in the future...

but to be honest they have offset in Inkscape but I never like offset tools because they are always produce unreliable results and usually requires manual intervention to correct nodes.

yorik

2011-10-22 12:14

administrator   ~0001186

Thanks for the link, interesting anyway. Actually OCC should be able to produce an offset too, I'll have a look...

yorik

2012-01-16 20:07

administrator   ~0001582

Finally implemented!

Was easier than I thought since the Part module can give you perpendicular and tangent points on a curve. But as Luke says it doesn't always give the desired result, since what is offsetted are the control points, and the curvature can change depending on the new distance between the control points.

But recalculating the correct curvature is honestly a bit beyond my skills at the moment... I think for now it is ok to leave it that way. Reopen if any issue appear.

unauthenticated

2013-06-01 12:06

viewer   ~0003187

I did make a spline "C" shape and then close it with the c key. I want to offset it, but can't. (1830 git)

Issue History

Date Modified Username Field Change
2011-02-17 17:23 unauthenticated New Issue
2011-02-17 21:14 unauthenticated Note Added: 0000617
2011-02-17 21:15 yorik Status new => assigned
2011-02-17 21:15 yorik Assigned To => yorik
2011-02-18 07:12 unauthenticated Note Added: 0000620
2011-10-17 17:43 yorik Note Added: 0001174
2011-10-17 17:43 yorik Priority normal => low
2011-10-17 17:43 yorik Target Version => 0.13
2011-10-17 17:43 yorik Summary Make th offset function working on b-splines => Make the Draft offset function working on b-splines
2011-10-22 06:56 mrlukeparry Note Added: 0001183
2011-10-22 12:14 yorik Note Added: 0001186
2012-01-16 20:07 yorik Note Added: 0001582
2012-01-16 20:07 yorik Status assigned => closed
2012-01-16 20:07 yorik Resolution open => fixed
2012-01-16 20:07 yorik Fixed in Version => 0.13
2013-06-01 12:06 unauthenticated Note Added: 0003187
2013-06-01 12:06 unauthenticated Status closed => feedback
2013-06-01 12:06 unauthenticated Resolution fixed => reopened
2013-07-05 22:11 yorik Project FreeCAD => Draft
2013-12-23 01:32 yorik Status feedback => assigned
2014-01-01 16:01 yorik Changeset attached => FreeCAD Master master 2bc15af1
2014-01-01 16:01 yorik Status assigned => closed