View Issue Details

IDProjectCategoryView StatusLast Update
0002683PartDesignFeaturepublic2018-12-16 20:15
ReporternormandcAssigned ToDeepSOIC 
PrioritynormalSeverityfeatureReproducibilityN/A
Status closedResolutionfixed 
Product Version0.17 
Target Version0.18Fixed in Version0.17 
Summary0002683: Add Refine shape feature to PartDesign
DescriptionIn PartDesign Next, creating a Refine shape feature from the OpenSCAD workbench on a PartDesign feature used to be possible. Now, two things happen:

[list=1]
[*]The OpenSCAD Refine Shape feature breaks the chain of features, and is created outside of the active Body.
[*]The created feature fails with a "Links go out of the allowed scope" error.
[/list]

While the Body itself can be selected for the Refine shape feature, refining a PartDesign feature under a Body may be necessary for some ulterior operations such as fillets or chamfers.

This feature request asks for a new dedicated PartDesign tool, but would it be possible to make the OpenSCAD feature compatible instead? For example, the Sheet Metal workbench add-on was made to be compatible with Bodies.
TagsNo tags attached.

Relationships

parent of 0003488 closedDeepSOIC Primitive elements and Booleans in PartDesign should have a refine property 
related to 0003142 confirmed Crash creating fillets on sweep 

Activities

abdullah

2017-06-11 10:47

manager   ~0009342

I think this is quite a show stopper because as the complexity of a model increases, the likelihood of "internal edges" preventing a correct fillet increases exponentially. I am resorting to refine the endshape of a body and filleting with part->fillet, which is not right.

I will try to do something about it.

abdullah

2017-06-13 15:20

manager   ~0009355

Discussion:
https://forum.freecadweb.org/viewtopic.php?f=19&t=22895

normandc

2018-01-14 23:04

manager   ~0010765

Since this report was originally introduced, behaviour has changed, as Scope was introduced; also added question about making the existing OpenSCAD tool compatible instead of creating a new command that duplicates existing functionality.

wmayer

2018-01-20 13:14

administrator   ~0010801

This adds properties to the feature types:
https://github.com/FreeCAD/FreeCAD/commit/27701ae8529f11627f5d036700cf0fcafb1c5153
https://github.com/FreeCAD/FreeCAD/commit/478611371b090791a32889eeb05ee6ba85ecf175

Open part of the report is to prepare OpenSCAD refine feature to the new PDN logic

normandc

2018-01-27 15:31

manager   ~0010876

Is that really necessary? I was not expecting the solution to be implemented with a Refine property under each feature, but now that it is, I think ensuring compatibility of OpenSCAD Refine feature would be redundant. I think it would be OK to close this report as resolved.

normandc

2018-06-12 21:33

manager   ~0011416

IMO with the addition of the Refine property for most PD features, we can consider this report resolved. We don't need to make OpenSCAD Refine Shape feature compatible with PD features. We are not supposed to link to individual PD features from outside anyway - just to the Body itself.

normandc

2018-11-27 02:25

manager   ~0012225

As explained in the comments, the requested functionality has been provided by adding a "Refine" property to all PartDesign features (work done by DeepSOIC), said property defined by the "automatically refine..." setting in Preferences/Part design/General.

Therefore, this report can be considered resolved.

normandc

2018-12-16 20:15

manager   ~0012284

Seems like resolving is not the same as closing an issue.

Issue History

Date Modified Username Field Change
2016-08-28 07:47 normandc New Issue
2017-06-11 10:44 abdullah Assigned To => abdullah
2017-06-11 10:44 abdullah Status new => assigned
2017-06-11 10:47 abdullah Note Added: 0009342
2017-06-13 15:20 abdullah Note Added: 0009355
2017-06-28 17:04 Kunda1 Target Version => 0.17
2017-08-21 11:11 Kunda1 Relationship added related to 0003142
2018-01-14 23:04 normandc Description Updated View Revisions
2018-01-14 23:04 normandc Note Added: 0010765
2018-01-18 10:38 DeepSOIC Assigned To abdullah => DeepSOIC
2018-01-20 13:14 wmayer Note Added: 0010801
2018-01-27 15:31 normandc Note Added: 0010876
2018-03-12 09:34 wmayer Target Version 0.17 => 0.18
2018-05-20 15:42 normandc Relationship added parent of 0003488
2018-06-12 21:29 DeepSOIC Assigned To DeepSOIC =>
2018-06-12 21:33 normandc Note Added: 0011416
2018-10-09 14:57 Kunda1 Status assigned => confirmed
2018-11-27 02:25 normandc Assigned To => DeepSOIC
2018-11-27 02:25 normandc Status confirmed => resolved
2018-11-27 02:25 normandc Resolution open => fixed
2018-11-27 02:25 normandc Fixed in Version => 0.17
2018-11-27 02:25 normandc Note Added: 0012225
2018-12-16 20:15 normandc Status resolved => closed
2018-12-16 20:15 normandc Note Added: 0012284