View Issue Details

IDProjectCategoryView StatusLast Update
0002678FreeCADBugpublic2016-08-22 21:01
ReporterflorianfreitagAssigned Towmayer 
PrioritylowSeveritytextReproducibilityalways
Status closedResolutionfixed 
PlatformLinuxOSUbuntuOS Version14.04
Product Version0.16 
Target VersionFixed in Version0.17 
Summary0002678: file names with underscores are not displayed correctly in recent files menu
DescriptionFile names with including underscores (for example test_1) are not displayed correctly in recent files menu.
But files are open correctly.
See screenshot.

Steps To Reproduce1. create freecad file with underscore in filename
2. open this file
3. go to file > recent files menu
Additional InformationOS: Ubuntu 14.04.5 LTS
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.16.6698 (Git)
Build type: None
Branch: master
Hash: ca7c5d31a4d61f32a25b71025b14641a6e378328
Python version: 2.7.6
Qt version: 4.8.6
Coin version: 4.0.0a
OCC version: 6.8.0.oce-0.17
TagsNo tags attached.

Activities

florianfreitag

2016-08-19 13:06

reporter  

screen_freecad_recent_file_bug.jpg (Attachment missing)

wmayer

2016-08-21 16:54

administrator   ~0007292

I can confirm this under Ubuntu 14.04 when using Unity. However, with the xfce desktop or older Ubuntu versions it doesn't occur. So, I guess it's rather a bug in Unity than in FreeCAD.

florianfreitag

2016-08-22 19:19

reporter   ~0007293

For Windows 10 the problem does not exist for me.

wmayer

2016-08-22 21:01

administrator   ~0007294

Although it's not a bug in FreeCAD but very likely in Unity I have removed the &. Actually it was supposed to support mnemonics but since in sub-menus this doesn't work very well it's no loss in functionality.

Issue History

Date Modified Username Field Change
2016-08-19 13:06 florianfreitag New Issue
2016-08-19 13:06 florianfreitag File Added: screen_freecad_recent_file_bug.jpg
2016-08-21 16:54 wmayer Note Added: 0007292
2016-08-21 16:54 wmayer Status new => confirmed
2016-08-22 19:19 florianfreitag Note Added: 0007293
2016-08-22 20:52 wmayer Changeset attached => FreeCAD Master master 51e23d85
2016-08-22 21:01 wmayer Note Added: 0007294
2016-08-22 21:01 wmayer Status confirmed => closed
2016-08-22 21:01 wmayer Assigned To => wmayer
2016-08-22 21:01 wmayer Resolution open => fixed
2016-08-22 21:01 wmayer Fixed in Version => 0.17