View Issue Details

IDProjectCategoryView StatusLast Update
0000266FreeCADBugpublic2011-02-13 18:23
ReporterunauthenticatedAssigned Toyorik 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.11 
Target VersionFixed in Version0.12 
Summary0000266: Snapping + Ctrl does not work in 3D
DescriptionOne can't snap to all endpoints/midpoints of a box (by pressing the Ctrl key)

make two boxes -> try to move one and try to snap (holding down the Ctrl key) it to the corners(/midpoints of the lines) of the second box -> you can only snap to some corners but not to all of them.

Don't know if this is really a bug cause the draft module was created for 2D?

FreeCAD_0.11.3987_x86_unstable_setup.msi
TagsNo tags attached.

Relationships

child of 0000218 closedyorik CPU 100% when snapping 

Activities

yorik

2011-02-13 12:57

administrator   ~0000610

This bug is there since the beginning, looks like something wrong with coin selection mechanism. But I'll have a better look, maybe there is something I can do at the Draft level.

unauthenticated

2011-02-13 16:27

viewer   ~0000612

Ooops didn't know that.
thanks

yorik

2011-02-13 18:23

administrator   ~0000614

Done in r4057

I did a couple of optimizations and found some bugs too, I think it works far better already. The only glitches remaining are still dependent of the coin selection mechanism itself (for example, if you rotate the view while drawing, the view gets a bit "lost" between what's at the front and what's at the back)

but outside this 3D snapping works more or less reliably now.

I'll close this bug for now, but don't hesitate to reopen if some specific case arises again.

Issue History

Date Modified Username Field Change
2011-02-12 20:45 unauthenticated New Issue
2011-02-13 12:57 yorik Note Added: 0000610
2011-02-13 12:57 yorik Status new => assigned
2011-02-13 12:57 yorik Assigned To => yorik
2011-02-13 16:27 unauthenticated Note Added: 0000612
2011-02-13 18:21 yorik Relationship added child of 0000216
2011-02-13 18:22 yorik Relationship deleted child of 0000216
2011-02-13 18:22 yorik Relationship added child of 0000218
2011-02-13 18:23 yorik Note Added: 0000614
2011-02-13 18:23 yorik Status assigned => closed
2011-02-13 18:23 yorik Resolution open => fixed
2011-02-13 18:23 yorik Fixed in Version => 0.12