View Issue Details

IDProjectCategoryView StatusLast Update
0002640FEM[FreeCAD] Bugpublic2017-01-09 14:52
ReporterilyxaAssigned To 
PrioritylowSeveritycrashReproducibilityalways
Status closedResolutionfixed 
Platformx86_64OSArchOS VersionLinux 4.6.4
Product Version 
Target VersionFixed in Version[FreeCAD] 0.17 
Summary0002640: FEM crash
DescriptionCatchpoint 1 (signal SIGSEGV), 0x00007fffbeec8a57 in QMetaObject::className() const () from /usr/lib/libQt5Core.so.5
Steps To Reproducerun freecad (gdb freecad, catch signal, run), select FEM workbench.
Additional InformationOS: Linux
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.17.8044 (Git)
Build type: Unknown
Branch: makepkg
Hash: 41307ef5a18e36e9d29bc90dbfe05a0fa15aef23
Python version: 2.7.12
Qt version: 4.8.7
Coin version: 3.1.3
OCC version: 6.9.1
TagsNo tags attached.

Activities

ilyxa

2016-07-25 09:46

reporter   ~0007215

[ilyxa@orca freecad-git]$ LC_ALL=C gdb freecad
GNU gdb (GDB) 7.11.1
Copyright (C) 2016 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law. Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-pc-linux-gnu".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>.
Find the GDB manual and other documentation resources online at:
<http://www.gnu.org/software/gdb/documentation/>.
For help, type "help".
Type "apropos word" to search for commands related to "word"...
Reading symbols from freecad...(no debugging symbols found)...done.
(gdb) catch signal
Catchpoint 1 (standard signals)
(gdb) r
Starting program: /usr/bin/freecad
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/usr/lib/libthread_db.so.1".
FreeCAD 0.17, Libs: 0.17R8044 (Git)
© Juergen Riegel, Werner Mayer, Yorik van Havre 2001-2015
  ##### #### ### ####
  # # # # # #
  # ## #### #### # # # # #
  #### # # # # # # # ##### # #
  # # #### #### # # # # #
  # # # # # # # # # ## ## ##
  # # #### #### ### # # #### ## ## ##


Catchpoint 1 (signal SIGSEGV), 0x00007fffbeec8a57 in QMetaObject::className() const () from /usr/lib/libQt5Core.so.5
(gdb) c
Continuing.
*** Abort *** an exception was raised, but no catch was found.
        ... The exception is:SIGSEGV 'segmentation violation' detected. Address 7ffff6060e00

Catchpoint 1 (signal SIGSEGV), 0x00007fffbfbab393 in ?? () from /usr/lib/libQt5Widgets.so.5
(gdb) c
Continuing.
*** Abort *** an exception was raised, but no catch was found.
        ... The exception is:SIGSEGV 'segmentation violation' detected. Address 0

Catchpoint 1 (signal SIGSEGV), 0x00007ffff59b8913 in ?? () from /usr/lib/libQtGui.so.4
(gdb) c
Continuing.
*** Abort *** an exception was raised, but no catch was found.
        ... The exception is:SIGSEGV 'segmentation violation' detected. Address 0
[Inferior 1 (process 23594) exited with code 01]
(gdb)

wmayer

2016-07-28 17:34

administrator   ~0007222

You are linking with a library that depends on Qt5. This won't work.

wmayer

2017-01-09 14:52

administrator   ~0007577

This was caused by linking FreeCAD against vtk with one of its componnets linked against Qt5. To fix this FreeCAD now defines a certain set of vtk components.

Issue History

Date Modified Username Field Change
2016-07-25 09:42 ilyxa New Issue
2016-07-25 09:46 ilyxa Note Added: 0007215
2016-07-28 17:34 wmayer Note Added: 0007222
2017-01-09 14:52 wmayer Note Added: 0007577
2017-01-09 14:52 wmayer Status new => closed
2017-01-09 14:52 wmayer Resolution open => fixed
2017-01-09 14:52 wmayer Fixed in Version => 0.17