View Issue Details

IDProjectCategoryView StatusLast Update
0002631FreeCADBugpublic2016-10-20 07:55
ReporterJason C. WellsAssigned Towmayer 
PrioritylowSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformWindows 7 64 BitOSOS Version
Product Version0.16 
Target VersionFixed in Version0.17 
Summary0002631: Ctrl-W Doesn't Close Window
DescriptionPress the keyboard shortcut ctrl-w does not close the window. This is true for modified files and unmodified files. The menu pick works as expected.
Steps To ReproduceOpen any file. Press ctrl-w. Nothing happens.
TagsNo tags attached.

Activities

wmayer

2016-07-22 14:48

administrator   ~0007209

Last edited: 2016-07-22 14:49

View 2 revisions

It looks like a focus problem. When creating a new document then Ctrl+W doesn't work. But when setting the focus e.g. to the output window or the Python console then Ctrl+W shows the expected behaviour.

wmayer

2016-10-20 07:55

administrator   ~0007407

In the past CTRL+F4 was used to close a window but then QMdiSubWindow used the same shortcut and thus caused an ambiguity. Then CTRL+W was used instead but from a certain Qt version also this shortcut was used as an alternative and again caused an ambiguity.

To fix this issue again the shortcut of the CloseAction of the QMdiSubWindow must be reset. Btw, the command StdCmdCloseActiveWindow doesn't hard-code CTRL+W any more but uses QKeySequence::Close which sets the shortcut to the original version CTRL+F4 again.

Issue History

Date Modified Username Field Change
2016-07-22 06:33 Jason C. Wells New Issue
2016-07-22 14:48 wmayer Note Added: 0007209
2016-07-22 14:48 wmayer Status new => confirmed
2016-07-22 14:49 wmayer Note Edited: 0007209 View Revisions
2016-10-20 07:47 wmayer Changeset attached => FreeCAD Master master 6b1866cc
2016-10-20 07:55 wmayer Note Added: 0007407
2016-10-20 07:55 wmayer Status confirmed => closed
2016-10-20 07:55 wmayer Assigned To => wmayer
2016-10-20 07:55 wmayer Resolution open => fixed
2016-10-20 07:55 wmayer Fixed in Version => 0.17