View Issue Details

IDProjectCategoryView StatusLast Update
0000259FreeCADBugpublic2011-03-30 09:16
ReporterunauthenticatedAssigned ToJriegel 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target Version0.12Fixed in Version0.12 
Summary0000259: Can't select points in Sketcher
Descriptiondraw a rectangle in the draft module, new sketch, draw a box in sketcher, one can't select points of the box


FreeCAD_0.11.3987_x86_unstable_setup.msi
TagsNo tags attached.

Activities

wmayer

2011-02-10 12:56

administrator   ~0000586

I don't think it's a bug because point selection is not implemented. It only works when editing a sketch but otherwise not.

unauthenticated

2011-02-10 15:26

viewer   ~0000589

I mean when editing a sketch.

So: new file -> draw rectangle (draft module) -> new sketch -> draw a box (in sketcher) -> try to select a point (still in "editmode" of Sketcher) -> if you click on a point the point wont become green, if you mouseover a point the point wont become blue.
If you draw a sketch without having drawn something with the Draft module the point becomes blue/green when in "editmode" of Sketcher.

Jriegel

2011-02-10 18:52

administrator   ~0000591

I can not reproduce this error!? I can select and drag a point in
a sketch in edit.

And what you mean with Draft?

unauthenticated

2011-02-10 19:28

viewer   ~0000592

To reproduce this you HAVE to draw something with the "draft module" FIRST. If you use Sketcher WITHOUT drawing something with the "Draft module" first it WORKS.

1. Draw some circles or rectangles
2. Draw a box in Sketcher and try to click on a point -> the point wont be selected (wont become blue)

Draft module: http://sourceforge.net/apps/mediawiki/free-cad/index.php?title=Draft_Workbench

pperisin

2011-02-10 21:23

reporter   ~0000593

yes, I can see this too. But you DO select them, only they do not change color when they are selected, nor when you hoover mouse over them

Regards
Petar Perisin

unauthenticated

2011-02-10 22:07

viewer   ~0000594

Yes I think I should have called it mark instead of select. (Or color ??)

wmayer

2011-02-10 23:30

administrator   ~0000596

Yes, now I can see this behaviour, too.

Jriegel

2011-02-11 14:35

administrator   ~0000607

Ok confirmed.

strange behaviour!?

wmayer

2011-03-30 09:12

administrator   ~0000759

This error seems to be solved now. I don't know which of the many changes in the sketcher module fix it but it is not there any more.

Issue History

Date Modified Username Field Change
2011-02-10 10:53 unauthenticated New Issue
2011-02-10 12:56 wmayer Note Added: 0000586
2011-02-10 12:56 wmayer Assigned To => Jriegel
2011-02-10 12:56 wmayer Status new => assigned
2011-02-10 15:26 unauthenticated Note Added: 0000589
2011-02-10 18:52 Jriegel Note Added: 0000591
2011-02-10 19:28 unauthenticated Note Added: 0000592
2011-02-10 21:23 pperisin Note Added: 0000593
2011-02-10 22:07 unauthenticated Note Added: 0000594
2011-02-10 23:30 wmayer Note Added: 0000596
2011-02-10 23:30 wmayer Status assigned => confirmed
2011-02-11 14:35 Jriegel Note Added: 0000607
2011-02-11 14:39 Jriegel Target Version => 0.11
2011-03-30 09:12 wmayer Note Added: 0000759
2011-03-30 09:12 wmayer Status confirmed => closed
2011-03-30 09:12 wmayer Resolution open => fixed
2011-03-30 09:12 wmayer Fixed in Version => trunk
2011-03-30 09:16 wmayer Fixed in Version trunk => 0.12
2011-03-30 09:16 wmayer Target Version 0.11 => 0.12