View Issue Details

IDProjectCategoryView StatusLast Update
0000252FreeCADFeaturepublic2011-02-06 14:27
ReporterunauthenticatedAssigned Toyorik 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version0.11 
Summary0000252: extrude along normals
DescriptionWhen I select a face and make the face my "Work Plane" and try to extrude by holding down the SHIFT key the face is extruded along the global X-/Y-axis (I think). It would be nice if one could extrude along the normal of the selected face. Don't know if this is a good idea to replace the horizontal/vertical function with the extrude along normals when a face is selected as a working plane. I guess it would be better to add another shortcut.
TagsNo tags attached.

Activities

yorik

2011-02-05 11:51

administrator   ~0000579

Hm I think the problem is that when a workplane is selected, SHIFT-extruding a face doesn't work correctly because the normal gets "shrinked" on the working plane.

I'll fix that behaviour, indeed it would be better not to respect the working plane when shift is pressed.

yorik

2011-02-06 14:27

administrator   ~0000580

fixed in r4020

Issue History

Date Modified Username Field Change
2011-02-04 20:20 unauthenticated New Issue
2011-02-05 11:51 yorik Note Added: 0000579
2011-02-05 11:51 yorik Status new => assigned
2011-02-05 11:51 yorik Assigned To => yorik
2011-02-06 14:27 yorik Note Added: 0000580
2011-02-06 14:27 yorik Status assigned => closed
2011-02-06 14:27 yorik Resolution open => fixed
2011-02-06 14:27 yorik Fixed in Version => 0.11