View Issue Details

IDProjectCategoryView StatusLast Update
0002487DraftBugpublic2016-04-28 20:10
Reporterr-frankAssigned Toyorik 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformLinuxOSLinux MintOS Version17 - Qiana
Product Version0.15 
Target VersionFixed in Version0.16 
Summary0002487: Nearest snaps not to intersect
DescriptionWhen selecting snap "nearest" intersection of two draft lines is not recognized.
On Windows that works ...
Steps To ReproduceLook at this thread for more information:
http://forum.freecadweb.org/viewtopic.php?f=3&t=15050
TagsNo tags attached.

Activities

yorik

2016-03-31 22:32

administrator   ~0006940

Why would intersections be recognized by the nearest snap? Isn't it intersection snapping that you need?

r-frank

2016-04-01 17:54

reporter   ~0006941

Intersections (and endpoint snaps) as nearest snaps are recognized on Windows and they AREN'T on Linux.
At least that should be made the same behaviour ?
I'm talking about nearest snaps behaving completely different on different platforms ...
(OK, maybe it's more an enhancement request than a real bug report ...)

yorik

2016-04-26 22:56

administrator   ~0007010

I don't have a windows machine to test unfortunately, but I can't find anything in the code that would produce a different result on windows and linux... could it be because your snap range value is different? (Tools -> Parameters -> Mod -> Draft -> snapRange)

r-frank

2016-04-28 20:02

reporter   ~0007023

I just verified with 0.16.6700 on Windows 7 64-bit and 0.16.6698 on Linux Mint 17.
In both FreeCAD's NO snaprange is set.
BUT now both versions work the same way with intersection snap and with nearest snap.

So maybe your small fix did the trick or it was another commit.
Anyway, thanks for looking into this matter.
We can consider the case closed.

Have a nice day.

yorik

2016-04-28 20:10

administrator   ~0007024

Yeah, the problem probably got fixed without wanting... Okay then, closing it!

Issue History

Date Modified Username Field Change
2016-03-31 14:47 r-frank New Issue
2016-03-31 22:32 yorik Note Added: 0006940
2016-03-31 22:34 yorik Changeset attached => FreeCAD Master master f526ff8f
2016-04-01 17:54 r-frank Note Added: 0006941
2016-04-26 22:56 yorik Note Added: 0007010
2016-04-26 22:56 yorik Assigned To => yorik
2016-04-26 22:56 yorik Status new => feedback
2016-04-28 20:02 r-frank Note Added: 0007023
2016-04-28 20:02 r-frank Status feedback => assigned
2016-04-28 20:10 yorik Note Added: 0007024
2016-04-28 20:10 yorik Status assigned => closed
2016-04-28 20:10 yorik Resolution open => fixed
2016-04-28 20:10 yorik Fixed in Version => 0.16