View Issue Details

IDProjectCategoryView StatusLast Update
0002392FreeCADBugpublic2016-07-24 09:33
Reporterjean-baptisteAssigned Towmayer 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformLinuxOSFedoraOS Version23
Product Version0.15 
Target VersionFixed in Version0.17 
Summary0002392: tiny caracter encoding problems
DescriptionIn fedora 23 with french language, I have some wrongly encoded caracters.
Steps To ReproduceYou can see it in two places :
in help => about : Branch: (détaché de origin/releases/FreeCAD-0-15)
in welcome page "Sur le web" with problems with "'" : Page d\'accueil FreeCAD

I tried many menus, but haven't find other problems yet
Additional InformationOS: "Fedora release 23 (Twenty Three)"
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.15.4671 (Git)
Branch: (détaché de origin/releases/FreeCAD-0-15)
Hash: 244b3aef360841646cbfe80a1b225c8b39c8380c
Python version: 2.7.10
Qt version: 4.8.7
Coin version: 3.1.3
TagsNo tags attached.

Activities

wmayer

2016-01-07 18:15

administrator   ~0006685

Can you tell me please what "détaché" is supposed to be? What I have found out at least is that the string comes from the Python script SubWCRef.py

jean-baptiste

2016-05-06 10:17

reporter   ~0007055

Sorry, I had to reopen to answer.

Thanks for your fix. I can't reproduce this bug with version 1.16 available in f23 as the text written is "Unknown".
When reading your patch, I assume it fix the issue.

But when going to your translation platform, french is 100% :
https://crowdin.com/project/freecad/fr#

So why is it written "Unknown" ?

jean-baptiste

2016-05-06 10:33

reporter   ~0007057

Note : the second bug has not been corrected :
please have a look at this screenshot : https://holcroft.fr/oc/index.php/s/tDWWrvnBgbB52Qq
There is back-slashes before apostrophe.

On the first screen :
 * block "Sur le web" (on the web) => yes, the bug is present
 * block "Exemples de projets" (projects examples) => yes, the bug is present
 * block "recent files" => no problem
 * block "last commits" => no problem
 * block "start a new project" => can't try

Additional issue I didn't notice before :
 * the tab name is "Start page", it should be french also.

thanks for your help, it's just a tiny review but details matters.

wmayer

2016-05-06 11:19

administrator   ~0007058

Where in the About dialog does it say "Unknown"? This could be a problem of the Fedora package.

In the source tarball a file Version.h is deployed but when the package maintainer downloads the sources directly from git this file is not included. Then it will be created at build time and there it can happen that not all relevant information can be extracted and it simply writes "Unknown". This text does not go through the translation process.

jean-baptiste

2016-05-06 11:33

reporter   ~0007059

"Unknown" is written for "Revision number" and "Release date". Issue is the same in English when running FreeCAD in english :
# LANG=en_US.utf8 FreeCAD
I'll make a ticket in fedora bugtracker if you say so.

Issue History

Date Modified Username Field Change
2016-01-06 22:45 jean-baptiste New Issue
2016-01-07 18:15 wmayer Note Added: 0006685
2016-01-07 18:15 wmayer Status new => feedback
2016-05-05 19:14 wmayer Changeset attached => FreeCAD Master master 4ee20575
2016-05-05 19:14 wmayer Assigned To => wmayer
2016-05-05 19:14 wmayer Status feedback => closed
2016-05-05 19:14 wmayer Resolution open => fixed
2016-05-05 19:16 wmayer Fixed in Version => 0.17
2016-05-06 10:17 jean-baptiste Note Added: 0007055
2016-05-06 10:17 jean-baptiste Status closed => feedback
2016-05-06 10:17 jean-baptiste Resolution fixed => reopened
2016-05-06 10:33 jean-baptiste Note Added: 0007057
2016-05-06 10:33 jean-baptiste Status feedback => assigned
2016-05-06 11:19 wmayer Note Added: 0007058
2016-05-06 11:33 jean-baptiste Note Added: 0007059
2016-07-24 09:33 wmayer Status assigned => closed
2016-07-24 09:33 wmayer Resolution reopened => fixed