View Issue Details

IDProjectCategoryView StatusLast Update
0002391FreeCADBugpublic2016-01-19 02:03
ReportervidishaAssigned Toyorik 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
PlatformOSUbuntuOS Version14.04
Product Version 
Target VersionFixed in Version0.16 
Summary0002391: DXF export not working
DescriptionDXF export of part shapes or draft objects not working even for simple shapes. Using build from master branch:
OS: Ubuntu 14.04.3 LTS
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.16.6164 (Git)
Build type: Debug
Branch: master
Hash: 1e578c4f1ab09ce37acd6d4e73d4109827fff5a9
Python version: 2.7.6
Qt version: 4.8.6
Coin version: 4.0.0a
OCC version: 6.7.0
Steps To Reproduce- Run freecad from the terminal.
- Open the attached file rubber-foot.fcstd
- Select Pad
- From File menu select dxf export. Select a filename and save.

The terminal indicates downloading of dxf python scripts even though the scripts are already there.
Navigating to the folder where the file was supposed to be saved, shows no such file.
Additional Informationdxf export from the following build on 04 Jan 2016 works.
Version: 0.16.6163 (Git)
Hash: 273131c08857464fe7a140331afc864b7ae752f8

However dxf export for the fillet in the attached file causes crash.
Abort *** an exception was raised, but no catch was found.
    ... The exception is:SIGSEGV 'segmentation violation' detected. Address 0

Possibly another bug.
TagsNo tags attached.

Activities

vidisha

2016-01-05 02:11

reporter  

rubber-foot.fcstd (Attachment missing)

yorik

2016-01-05 14:16

administrator   ~0006668

small error in latest commit... it should work again now

vidisha

2016-01-05 19:32

reporter   ~0006672

Thank you for solving this problem. But the fundamental problem which has been in previous builds as well is freecad crashing on attempting to export dxf of a shape (fillet) such as attached here. Please see additional information section.

Non-handling fillets on edges between a curved face and a straight face might be the causing it. Please see attached pdf.

vidisha

2016-01-05 19:32

reporter  

foot.pdf (Attachment missing)

yorik

2016-01-06 12:51

administrator  

exported fillet.dxf (Attachment missing)

yorik

2016-01-06 12:53

administrator   ~0006676

I can export your fillet object without problems (see attached dxf file), no crash...

Can you describe exactly what I must do to make the crash happen?

vidisha

2016-01-08 19:07

reporter   ~0006694

I opened up the file in Freecad. From the file menu I selected export and format as Autodesk DXF. Hit save. Freecad crashes. The command line indicates this exception:
*** Abort *** an exception was raised, but no catch was found.
    ... The exception is:SIGSEGV 'segmentation violation' detected. Address 0

I have also tried using the draft workbench to create a facebinder object and export that. That crashes freecad as well. Another thing I tried was to use 2D Shape view tool. I selected the 'Fillet' and clicked on 2D shape view tool. It crashed freecad.

I did a fresh checkout and build of freecad's most recent version of master today. The above issues are reproduced every time. My OS is Ubuntu 14.04 and OCC version is 6.7.0.

vidisha

2016-01-09 00:08

reporter   ~0006695

This behavior is seen on 2 other computers at my workplace, one has the build version from 4 Jan 2016 and the other has a build version from 2014. Both these computers have OS as Ubuntu 14.04.

yorik

2016-01-09 00:25

administrator   ~0006696

Can you check if all the machines are using the OCE 0.15 version of opencascade? There are many bug reports with this version...

vidisha

2016-01-11 19:20

reporter   ~0006710

It seems the older OCE may have been the cause of the crash. My machine and the other two had version 0.15. I updated my OCE to the latest master build and the crash does not occur anymore. Thank you.

yorik

2016-01-19 02:02

administrator   ~0006732

ok then I'll close this report. Don't hesitate to reopen if needed.

Issue History

Date Modified Username Field Change
2016-01-05 02:11 vidisha New Issue
2016-01-05 02:11 vidisha File Added: rubber-foot.fcstd
2016-01-05 14:16 yorik Changeset attached => FreeCAD Master master c5b8b7c0
2016-01-05 14:16 yorik Assigned To => yorik
2016-01-05 14:16 yorik Status new => closed
2016-01-05 14:16 yorik Resolution open => fixed
2016-01-05 14:16 yorik Note Added: 0006668
2016-01-05 19:32 vidisha Note Added: 0006672
2016-01-05 19:32 vidisha Status closed => feedback
2016-01-05 19:32 vidisha Resolution fixed => reopened
2016-01-05 19:32 vidisha File Added: foot.pdf
2016-01-06 12:51 yorik File Added: exported fillet.dxf
2016-01-06 12:53 yorik Note Added: 0006676
2016-01-08 19:07 vidisha Note Added: 0006694
2016-01-08 19:07 vidisha Status feedback => assigned
2016-01-09 00:08 vidisha Note Added: 0006695
2016-01-09 00:25 yorik Note Added: 0006696
2016-01-09 00:26 yorik Status assigned => feedback
2016-01-11 19:20 vidisha Note Added: 0006710
2016-01-11 19:20 vidisha Status feedback => assigned
2016-01-19 02:02 yorik Note Added: 0006732
2016-01-19 02:03 yorik Status assigned => closed
2016-01-19 02:03 yorik Resolution reopened => fixed
2016-01-19 02:03 yorik Fixed in Version => 0.16