View Issue Details

IDProjectCategoryView StatusLast Update
0002390FreeCADBugpublic2016-01-13 12:57
ReporterreportingsjrAssigned To 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version0.15 
Target VersionFixed in Version0.16 
Summary0002390: VRML exporter using invalid names
DescriptionWhile testing a new VRML renderer for KiCad it was noticed that FreeCAD apparently generates VRML files with names in DEF blocks that aren't allowed according to the standards.

The following characters aren't allowed in names in DEF blocks:
"'#+-,.\[]{}x00x01x02x03x04x05x06x09x0Ax0Bx0Cx0Dx0Ex0Fx11x12x13x14x15x16x17x18x19x1Ax1Bx1Cx1Dx1Ex1F

Looking at the file I have the naming scheme seems to be _+<num>. + isn't allowed as seen above.
TagsNo tags attached.

Activities

reportingsjr

2016-01-04 04:49

reporter  

pa1134.wrl (Attachment missing)

wmayer

2016-01-13 12:38

administrator   ~0006714

Here the link to the specs: http://www.web3d.org/documents/specifications/19776-2/V3.0/Part02/grammar.html#Nodes

Issue History

Date Modified Username Field Change
2016-01-04 04:49 reportingsjr New Issue
2016-01-04 04:49 reportingsjr File Added: pa1134.wrl
2016-01-13 12:38 wmayer Note Added: 0006714
2016-01-13 12:56 wmayer Changeset attached => FreeCAD Master master bf151fe5
2016-01-13 12:57 wmayer Status new => closed
2016-01-13 12:57 wmayer Resolution open => fixed
2016-01-13 12:57 wmayer Fixed in Version => 0.16