View Issue Details

IDProjectCategoryView StatusLast Update
0002389FreeCADBugpublic2016-02-19 22:29
ReporterAlmisuifreAssigned Toeivindkvedalen 
PriorityimmediateSeverityblockReproducibilityalways
Status closedResolutionfixed 
PlatformUbuntu Trusty LTS 64 bitsOSUbuntuOS VersionLinux version 3.
Product Version 
Target Version0.16Fixed in Version0.16 
Summary0002389: Crash systematic on the 10th sketch when employing a cavity.
DescriptionOn a complex part. Withdrawing from material becomes impossible. I can add but not remove.

This plant and the message appears in the console: Abort (core dumped)
Steps To Reproduce1 / Create a complex sketch
2 / Remove the material (a hole)
3 / Apply the hole on the front -> crash
TagsNo tags attached.

Relationships

has duplicate 0002451 closed FreeCAD crashes on selecting Mirrowed Part 

Activities

Almisuifre

2016-01-03 04:18

reporter  

Almi3K_A_Travail.fcstd (Attachment missing)

Almisuifre

2016-01-03 04:18

reporter  

Almi3K_A_1.fcstd (Attachment missing)

Almisuifre

2016-01-03 04:20

reporter   ~0006658

Solution found. Make "refine the shape." This causes a change in operations names.

File bug: Almi3K_A_Travail.fcstd
File repaired with the above indication: Almi3K_A_1.fcstd

I suspect that this is the automatic naming of the cavity function that crashes FreeCAD.
For information, the manual naming (F2) does not change the problem.

eivindkvedalen

2016-01-03 10:41

developer   ~0006659

Confirmed. Asserts on ExpressionBinding.cpp:80 (prop != 0).

wmayer

2016-01-26 20:23

administrator   ~0006758

I have to reopen this ticket since the commit caused a show stopper regression and thus I reverted it.

Issue History

Date Modified Username Field Change
2016-01-03 03:32 Almisuifre New Issue
2016-01-03 04:18 Almisuifre File Added: Almi3K_A_Travail.fcstd
2016-01-03 04:18 Almisuifre File Added: Almi3K_A_1.fcstd
2016-01-03 04:20 Almisuifre Note Added: 0006658
2016-01-03 10:40 eivindkvedalen Assigned To => eivindkvedalen
2016-01-03 10:40 eivindkvedalen Status new => assigned
2016-01-03 10:41 eivindkvedalen Note Added: 0006659
2016-01-09 12:08 Changeset attached => FreeCAD Master master 3aa44e6b
2016-01-26 11:06 wmayer Changeset attached => FreeCAD Master master 670eaf04
2016-01-26 11:18 wmayer Status assigned => closed
2016-01-26 11:18 wmayer Resolution open => fixed
2016-01-26 11:18 wmayer Fixed in Version => 0.16
2016-01-26 20:18 wmayer Changeset attached => FreeCAD Master master 1b8cd9b9
2016-01-26 20:23 wmayer Note Added: 0006758
2016-01-26 20:23 wmayer Resolution fixed => reopened
2016-01-26 20:24 wmayer Status closed => confirmed
2016-01-29 16:22 yorik Target Version => 0.16
2016-02-18 16:33 wmayer Changeset attached => FreeCAD Master master e5f1e298
2016-02-18 16:33 wmayer Status confirmed => closed
2016-02-18 16:33 wmayer Resolution reopened => fixed
2016-02-19 22:29 wmayer Relationship added has duplicate 0002451