View Issue Details

IDProjectCategoryView StatusLast Update
0002358FreeCADBugpublic2015-12-15 13:15
Reporterl3iggsAssigned Toyorik 
PriorityhighSeveritymajorReproducibilityalways
Status closedResolutionfixed 
PlatformOSLinuxOS Version
Product Version0.15 
Target VersionFixed in Version0.16 
Summary0002358: can not import .csg file
DescriptionWhen I attempt to import my .csg file, I get the following error message:
Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "/usr/share/freecad/Mod/OpenSCAD/importCSG.py", line 100, in insert
    if workaroundforissue128needed():
  File "/usr/share/freecad/Mod/OpenSCAD/OpenSCADUtils.py", line 91, in workaroundforissue128needed
    year,mon=int(vdate[0]),int(vdate[1])
<type 'exceptions.ValueError'>: invalid literal for int() with base 10: '03-2'
Steps To ReproduceAttempt to import a .csg file generated by OpenSCAD
TagsNo tags attached.

Activities

l3iggs

2015-12-10 14:29

reporter   ~0006585

My mistake:
This happens when I attempt to import or open my .scad file, not my .csg file

l3iggs

2015-12-10 14:37

reporter   ~0006586

I'm quite sure this error is due to the fact that running 'openscad -v' on my system (Arch Linux) returns 'OpenSCAD version 2015.03-2' and the workaroundforissue128needed function in Mod/OpenSCAD/OpenSCADUtils.py can't handle the '-2'.

l3iggs

2015-12-10 14:50

reporter   ~0006587

https://github.com/FreeCAD/FreeCAD/pull/68 fixes this.

Issue History

Date Modified Username Field Change
2015-12-10 14:25 l3iggs New Issue
2015-12-10 14:29 l3iggs Note Added: 0006585
2015-12-10 14:37 l3iggs Note Added: 0006586
2015-12-10 14:50 l3iggs Note Added: 0006587
2015-12-10 15:23 yorik Changeset attached => FreeCAD Master master b7a9bf95
2015-12-10 15:23 yorik Assigned To => yorik
2015-12-10 15:23 yorik Status new => closed
2015-12-10 15:23 yorik Resolution open => fixed
2015-12-15 13:15 yorik Fixed in Version => 0.16