View Issue Details

IDProjectCategoryView StatusLast Update
0000228FreeCADBugpublic2011-09-06 10:40
ReporterpperisinAssigned ToJriegel 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.11 
Target VersionFixed in Version0.12 
Summary0000228: Another preselection highlight bug
DescriptionHi,

There is a situation in which Part's face is highlighted with pre-selection color even when a mouse in not hovered over the part at all

1. Hover a mouse over an unselected Part so that one face gets pre-selection color
2. Rotate view with mouse (mid and left mouse button clicked) in a way that cursor gets out of the part (cursor is not over the part any more)
3. As soon as you release all mouse buttons (and cursor is not over the part) color of the face returns to be the color of the Part - GOOD
4. Do not move a mouse over the part - just press the middle mouse button and pan the view a little bit - you should see a face colored with pre-selection color, although mouse is not over the part at all - (BAD)
Additional InformationWin7 32 bit build 3839

This is not a bug with Pre-selection available in black-only.
TagsNo tags attached.

Activities

pperisin

2011-01-03 08:44

reporter   ~0000481

Last edited: 2011-01-03 09:22

Hi,

Just to add - this does not happen all the time. In order for this bug to appear you need to:

1. Select the part you will be testing in tree view (select)
2. Click once in workspace where part is shown (not over the part, but in empty space) to unselect it

After this make 4. steps in bug report

Regards

Jriegel

2011-01-15 15:56

administrator   ~0000517

I could reproduce it....
Will be hart to trace down...

pperisin

2011-01-17 10:29

reporter   ~0000537

Last edited: 2011-01-17 14:01

Maybe it can be worked around. When you start rotating, all pre-selection is removed + pre-selection is disabled. Seems good to me.

(Although I do not know how the system works, so this might be hard to do after all)

Regards
Petar Perisin

Jriegel

2011-05-17 08:11

administrator   ~0000829

I will leave that error since I anyway plan to overhaul the whole preselection

wmayer

2011-08-30 07:14

administrator   ~0001015

This bug must be related to the pre-selection/selection using the front-buffer in 32-bit. Since this technique doesn't work very well with 64-bit systems we do a repaint there. And on these systems this problem doesn't appear.

Also the new selection style doesn't use the front-buffer because due to the enormous reduction of Inventor nodes this isn't necessary anyway. There we don't have this problem either.

wmayer

2011-09-06 10:40

administrator   ~0001045

Using new Inventor classes for CAD shapes with built-in highlighting & selection this bug is fixed. See r4875

Issue History

Date Modified Username Field Change
2011-01-03 08:33 pperisin New Issue
2011-01-03 08:44 pperisin Note Added: 0000481
2011-01-03 09:22 pperisin Note Edited: 0000481
2011-01-15 15:56 Jriegel Note Added: 0000517
2011-01-15 15:56 Jriegel Assigned To => Jriegel
2011-01-15 15:56 Jriegel Status new => confirmed
2011-01-17 10:29 pperisin Note Added: 0000537
2011-01-17 10:30 pperisin Note Edited: 0000537
2011-01-17 10:30 pperisin Note Edited: 0000537
2011-01-17 14:01 pperisin Note Edited: 0000537
2011-05-17 08:11 Jriegel Note Added: 0000829
2011-05-26 06:57 Jriegel Status confirmed => assigned
2011-08-30 07:14 wmayer Note Added: 0001015
2011-09-06 10:40 wmayer Note Added: 0001045
2011-09-06 10:40 wmayer Status assigned => closed
2011-09-06 10:40 wmayer Resolution open => fixed
2011-09-06 10:40 wmayer Fixed in Version => 0.12