View Issue Details

IDProjectCategoryView StatusLast Update
0002274FreeCADBugpublic2015-09-24 11:34
ReporternicosflyAssigned Towmayer 
PrioritynormalSeverityfeatureReproducibilityalways
Status closedResolutionfixed 
PlatformLinuxOSOpenSUSEOS Version13.1
Product Version 
Target VersionFixed in Version0.16 
Summary0002274: numpad edition for size, position failed
DescriptionWhen moving or sizing a piece entering values by keyboard, the value is not set properly.
The problem exist for positions X, Y and Z, length, size, height, and angle.
it does not affect the axis X, Y and Z parameters.
Steps To ReproduceFor example, want x=35. Hit 3 and 5. The last key is taken, loosing the first one.
If I select for example 13.5, the result is .5
The dot selection make the following entered value correct.
When entering new value, is new char appears selected in the editor, and is automatically replaced by the next, without keeping the first one.
Additional InformationFreecad Version:
OS: "openSUSE 13.1 (Bottle) (x86_64)"
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.16.5525 (Git) (Packman)
Build type: Release
Branch: master
Hash: d3281a66eb416e3d636f5e108843455ecb44951d
Python version: 2.7.6
Qt version: 4.8.5
Coin version: 4.0.0a
OCC version: 6.8.0.oce-0.17
TagsNo tags attached.

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2015-09-24 09:27 nicosfly New Issue
2015-09-24 11:32 wmayer Changeset attached => FreeCAD Master master 29f827a5
2015-09-24 11:33 wmayer Relationship added duplicate of 0002223
2015-09-24 11:34 wmayer Relationship deleted 0002223
2015-09-24 11:34 wmayer Status new => closed
2015-09-24 11:34 wmayer Assigned To => wmayer
2015-09-24 11:34 wmayer Resolution open => fixed
2015-09-24 11:34 wmayer Fixed in Version => 0.16