View Issue Details

IDProjectCategoryView StatusLast Update
0000226FreeCADBugpublic2012-06-11 07:12
ReporterpperisinAssigned Towmayer 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.11 
Target Version0.11Fixed in Version0.11 
Summary0000226: Minor Bug with Box and Sphere not drawn correctly
DescriptionHi,

This is a minor bug. It works untill you redraw the view (I think). In order to reproduce it:
1. Open Freecad and create new document
2. Make box (from toolbar) but do not move the view (you should see bottom left corner of the cube)
3. Make sphere (from toolbar)

now you should see sphere over box. You can also see this if you zoom out with mouse (without rotating). After you rotate a bit, wiew refreshes and cube is drawn correctly over the sphere.

I hope I was clear

Regards
Petar Perisin
Additional InformationWin 7 32bit

Latest unstable build from web (0.11.3824) installed

TagsNo tags attached.

Activities

myier

2011-01-16 22:40

reporter   ~0000534

In rev. 3915, when creating a cone with the default camera position (new file), it is displayed as if the small part was in front, but it is actually behind. As soon as the camera is moved, the cone is redrawn in the correct side. I guess it's the same bug than reported here.

pperisin

2011-01-17 14:34

reporter   ~0000538

Ok, Further investigation revealed there is much more to this than it first seamed.

Try this: Create new document, sphere and box.

There is problem with all views - Top, Bottom, Left, Right, Front, Back - they all for some reason draw sphere above the box.

Now quite longshot guess:
I do not know where in the source code this is, but there has to be some parameter in which this sphere gets drawn after the cube.

Maybe this can be worked around with using rotation to simply set rotation to "front view" and leave it there (since rotation workes quite well, and setting top view - or any other view - does not)

Regards
Petar Perisin

Jriegel

2011-01-26 11:48

administrator   ~0000552

Seams the front and back cliping plane are to tight after insert a new shape...
Its a really small fraction. A slight rotation brings it on again.

Not sure we can do something...

pperisin

2011-01-26 12:47

reporter   ~0000556

Last edited: 2011-01-26 13:04

The Bug disappears if you use view fit command

after it all is well

can you set to have this comand activated after creating new shape. It is a workaround, and it will fix the bug.

Regards
Petar Perisin

pperisin

2011-01-26 20:46

reporter   ~0000559

Also, I do not like when I start FreeCAD and create a Box, that I see only bottom left part of it. This would solve it, as it would fit all objects after creation.

What do you think?

myier

2011-01-26 21:12

reporter   ~0000560

This is actually done when using the Part -> Parametric -> Create primitives... menu and not when using the shortcut icons for cube or sphere creation. Maybe it could be a good thing to homegenize this behavior, since using the menu is required for shapes that don't have an icon (ellipsod, helix, plane).

pperisin

2011-01-27 15:26

reporter   ~0000561

Yes.

Also, one more command that might need fit is: View >> Create New View. The same thing appears here.

wmayer

2011-02-28 12:11

administrator   ~0000665

OK, the point is that in all these cases the camera position lies inside the object and thus causes the strange rendering. So, the only proper solution is to do a fit-all at least for the first inserted object.

wmayer

2011-02-28 12:32

administrator   ~0000666

Fixed in rev. 4161/4162

pperisin

2012-06-11 06:28

reporter   ~0002171

Hi,

I get the same issue on importing STEP file. This could be fixed by making view fit when STEP file is imported.

Regards,
Petar

wmayer

2012-06-11 07:12

administrator   ~0002172

git show 180691d

Issue History

Date Modified Username Field Change
2010-12-28 12:46 pperisin New Issue
2010-12-28 16:03 wmayer Assigned To => wmayer
2010-12-28 16:03 wmayer Status new => confirmed
2011-01-16 22:40 myier Note Added: 0000534
2011-01-17 14:34 pperisin Note Added: 0000538
2011-01-26 11:48 Jriegel Note Added: 0000552
2011-01-26 12:47 pperisin Note Added: 0000556
2011-01-26 13:04 pperisin Note Edited: 0000556
2011-01-26 20:46 pperisin Note Added: 0000559
2011-01-26 21:12 myier Note Added: 0000560
2011-01-27 15:26 pperisin Note Added: 0000561
2011-02-28 12:11 wmayer Note Added: 0000665
2011-02-28 12:32 wmayer Note Added: 0000666
2011-02-28 12:32 wmayer Status confirmed => closed
2011-02-28 12:32 wmayer Resolution open => fixed
2011-02-28 12:32 wmayer Fixed in Version => 0.11
2011-02-28 12:32 wmayer Target Version => 0.11
2012-06-11 06:28 pperisin Note Added: 0002171
2012-06-11 06:28 pperisin Status closed => feedback
2012-06-11 06:28 pperisin Resolution fixed => reopened
2012-06-11 07:12 wmayer Note Added: 0002172
2012-06-11 07:12 wmayer Status feedback => closed
2012-06-11 07:12 wmayer Resolution reopened => fixed