View Issue Details

IDProjectCategoryView StatusLast Update
0002237FreeCADBugpublic2015-09-07 18:35
Reporterarnold.udeAssigned Toyorik 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformAmd64OSUbuntuOS Version15.04 64bit
Product Version 
Target VersionFixed in Version0.16 
Summary0002237: In 0.16 Rev 5432 (Git) Entering numbers is garbled, after first digit cursor jumps to end of field
DescriptionEntering numbers in part editor shows since Rev 5432 is broken. Whenever I enter a numeric constraint the cursor behaves not as expected.
Steps To ReproduceMake a line in the part editor and choose length constraint trying to change the suggested value say to 20mm. When you enter 20 it is expected that the entry field contains 20mm but in fact you end with 2mm0 , the cursors jumps after the first digit to the end of the field.
TagsNo tags attached.

Relationships

duplicate of 0002236 closedyorik Sketcher Issue with Insert lenght Dialog box entry field 

Activities

bejant

2015-09-02 10:34

reporter   ~0006320

Someone else also reported this as issue 2236:
http://www.freecadweb.org/tracker/view.php?id=2236

and a forum thread regarding this problem is here:
http://forum.freecadweb.org/viewtopic.php?f=3&t=12278

f3nix

2015-09-06 12:52

reporter   ~0006335

Hi,
this bug has been introduced in cb16fec6bb67cec15be3fc2aeb251ab524134073.

File: src/Gui/QuantitySpinBox.cpp
Line number: 70

Commenting it out solves this issue.

HTH.

Cheers,
Mateusz

Issue History

Date Modified Username Field Change
2015-09-02 09:05 arnold.ude New Issue
2015-09-02 10:34 bejant Note Added: 0006320
2015-09-02 16:05 yorik Relationship added duplicate of 0002236
2015-09-06 12:52 f3nix Note Added: 0006335
2015-09-07 18:34 yorik Changeset attached => FreeCAD Master master b4e3fcb4
2015-09-07 18:35 yorik Status new => closed
2015-09-07 18:35 yorik Assigned To => yorik
2015-09-07 18:35 yorik Resolution open => fixed
2015-09-07 18:35 yorik Fixed in Version => 0.16