View Issue Details

IDProjectCategoryView StatusLast Update
0002234PartDesignBugpublic2017-08-13 15:28
ReporterthorAssigned Toabdullah 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformLinuxOSUbuntuOS Version14.04.3 LTS
Product Version 
Target VersionFixed in Version0.17 
Summary0002234: Cannot create edge linked to external geometry if it's sweeped
DescriptionEdges of a planar face of geometry created via sweeping can't be referenced via the "Create edge linked to external geometry" tool.

There's no such issue with a sketch that has been extruded in the Part workbench. I did not test other means of geometry creation in the Part workbench, regarding this issue.

See attached test file.
Steps To Reproduce* Part Design workbench: Create 3 sketches with appropriate offsets and orientations: 2 rectangular profiles and a guide (single line or arc doesn't matter) for a sweep.
* Part workbench: create a sweep, check "solid".
* Part Design workbench: select a face on the side of the sweep, add a sketch
* Try to use "Create edge linked to external geometry" and note that no element will be added!
Additional InformationOS: Ubuntu 14.04.3 LTS
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.16.5371 (Git)
Build type: None
Branch: master
Hash: daa024cc79aaf440fe43fe8b47c060012b2891de
Python version: 2.7.6
Qt version: 4.8.6
Coin version: 4.0.0a
OCC version: 6.8.0.oce-0.17
Tagssweep

Activities

thor

2015-08-31 19:26

reporter  

test_sweep_ext_geo.fcstd (11,770 bytes)

normandc

2017-02-25 18:33

manager   ~0008434

Up to 0.16 this is as expected since the Sketcher didn't support B-splines. When trying to link unsupported external geometry, a message is printed in the Report view:

>Not yet supported geometry for external geometry
>Failed to add external geometry: Not able to add external shape element

Support for B-splines was just added to FreeCAD master, and they can now be linked to as external geometry. But not all constraints are supported yet, so I don't think this should be considered fixed for now.

OS: Ubuntu 16.04.2 LTS
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.17.10276 (Git)
Build type: None
Branch: master
Hash: 10191e90861cf0c87d24c1980761fd1c7f3cdde4
Python version: 2.7.12
Qt version: 4.8.7
Coin version: 4.0.0a
OCC version: 6.8.0.oce-0.17

Kunda1

2017-05-31 00:55

manager   ~0009209

@Abdullah I saw b-splines and thought of you ;)

abdullah

2017-05-31 13:20

manager   ~0009221

@kunda1

Here I agree with Normand on the facts, but I differ in the conclusion. The reasons for the divergence are:
1. The bug is about the imposibility to import external geometry of b-spline type (which in any case should be a feature request and not a bug report).
2. The current sketcher allows to import such external geometry.
3. While it is true that b-spline does not support certain constraints, and notably point on curve, which is limiting, I think that would be a feature request unrelated to this ticket.

I am ok though with whatever you decide to do with it.

normandc

2017-07-01 08:24

manager   ~0009630

Per @abdullah's comment I am closing this report as fixed in 0.17. It is now possible to create edge linked to external geometry that consist of B-splines as is the case with swept edges.

Kunda1

2017-08-13 15:28

manager   ~0009903

Closing.
[quote=abdullah]3. While it is true that b-spline does not support certain constraints, and notably point on curve, which is limiting, I think that would be a feature request unrelated to this ticket.[/quote]
@normandc should we open a Feature request for this? If not then don't respond. If so..do you mind opening one? ;)

Issue History

Date Modified Username Field Change
2015-08-31 19:26 thor New Issue
2015-08-31 19:26 thor File Added: test_sweep_ext_geo.fcstd
2017-02-17 13:57 Kunda1 Tag Attached: #pending
2017-02-17 13:57 Kunda1 Tag Attached: sweep
2017-02-25 18:33 normandc Note Added: 0008434
2017-05-31 00:50 Kunda1 Note View State: 0008434: private
2017-05-31 00:50 Kunda1 Note View State: 0008434: public
2017-05-31 00:51 Kunda1 Tag Detached: #pending
2017-05-31 00:55 Kunda1 Note Added: 0009209
2017-05-31 13:20 abdullah Note Added: 0009221
2017-07-01 08:24 normandc Assigned To => abdullah
2017-07-01 08:24 normandc Status new => resolved
2017-07-01 08:24 normandc Resolution open => fixed
2017-07-01 08:24 normandc Fixed in Version => 0.17
2017-07-01 08:24 normandc Note Added: 0009630
2017-08-13 15:28 Kunda1 Status resolved => closed
2017-08-13 15:28 Kunda1 Note Added: 0009903