View Issue Details

IDProjectCategoryView StatusLast Update
0002229FreeCADBugpublic2015-12-15 13:17
ReportersjoerdAssigned Towandererfan 
PrioritylowSeveritycrashReproducibilityalways
Status closedResolutionfixed 
PlatformlinuxOSarchlinux x86_64OS Versionup to date
Product Version0.15 
Target VersionFixed in Version0.16 
Summary0002229: some ttf fonts make Draft.makeShapeString crash
DescriptionSpecifically these fonts make freecad crash:
http://www.dafont.com/octin-college-free.font
http://www.dafont.com/usaaf-stencil.font

Steps To Reproducemake a shapeString through a direct python call to Draft.makeShapeString
or via the ShapeString Gui tool.
Additional InformationI have not tried many other fonts, but at least some other (ttf) fonts do work so it is something specific about these font files. I have tried the 0.16 git version of freecad and the issue is present there as well. I have attached one of the crashing ttf files.
TagsNo tags attached.

Activities

sjoerd

2015-08-26 12:48

reporter  

stencil.ttf (Attachment missing)

wandererfan

2015-08-26 23:43

developer   ~0006299

just for future reference, FontForge reports "points too close" and "paths intersect" errors for both these fonts.
This fix solves duplicate points.
USAAF_Stencil.ttf still has problems with some glyphs due to intersecting paths.

wandererfan

2015-08-26 23:45

developer   ~0006300

note re font definitions added.

Issue History

Date Modified Username Field Change
2015-08-26 12:48 sjoerd New Issue
2015-08-26 12:48 sjoerd File Added: stencil.ttf
2015-08-26 20:57 wmayer Changeset attached => FreeCAD Master master 8ec1bab1
2015-08-26 20:57 wmayer Assigned To => wmayer
2015-08-26 20:57 wmayer Status new => closed
2015-08-26 20:57 wmayer Resolution open => fixed
2015-08-26 20:57 wmayer Assigned To wmayer =>
2015-08-26 23:43 wandererfan Assigned To => wandererfan
2015-08-26 23:43 wandererfan Note Added: 0006299
2015-08-26 23:43 wandererfan Status closed => feedback
2015-08-26 23:43 wandererfan Resolution fixed => reopened
2015-08-26 23:45 wandererfan Note Added: 0006300
2015-08-26 23:45 wandererfan Status feedback => closed
2015-08-26 23:45 wandererfan Resolution reopened => fixed
2015-12-15 13:17 yorik Fixed in Version => 0.16