View Issue Details

IDProjectCategoryView StatusLast Update
0002217FreeCADBugpublic2017-01-24 12:29
ReporterspellmasterAssigned Towmayer 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformMacOSOSX OS Version10.10.1
Product Version0.15 
Target VersionFixed in Version0.17 
Summary0002217: Pockets disappear after toggling visibility
DescriptionWhen creating and changing a Part using a sketch its often handy to remove any 3D by toggling visibility.
Unfortunatly when a part has been created that contains a pocket. Toggling the 3D object back results in the pocket being filled in.
Steps To Reproducecreate a sketch. draw a simple square. make a pad.
create a new sketch that creates a pocket in the original square.
create a pocket
toggle visibility off/on
pad now appears filled in.
TagsNo tags attached.

Activities

Kunda1

2017-01-23 21:23

manager   ~0007925

OP please retest on 0.16
Also as an FYI when you post ticket in the future please add the contents of Help > About FreeCAD > Copy to clipboard

Forum thread: https://forum.freecadweb.org/viewtopic.php?f=10&t=20162

normandc

2017-01-24 05:11

manager   ~0007946

Last edited: 2017-01-24 05:13

View 2 revisions

The description is too vague to validate.

At step 4, "toggle visibility off/on"
Visibility of which element is being toggled? the Pad? the Pocket? Sketch or Sketch001?

If Pad's visibility is toggled on, it's normal that Pocket would be filled because both Pad and Pocket share the same space. Up to FreeCAD 0.16.670x you need to manually manage visibility of features.

But starting with 0.17 this is managed automatically, so it can be considered fixed in 0.17.

This matter should have been discussed in the forum first before reporting it here, as explained in the "READ THIS BEFORE REPORTING" link under the Issues menu.

wmayer

2017-01-24 10:23

administrator   ~0007949

That's actually an invalid report. Of course, the pocket looks filled in when showing the pocket and pad at the same time. In 0.17 it's not possible any more to show both at the same time.

Issue History

Date Modified Username Field Change
2015-08-17 17:06 spellmaster New Issue
2017-01-23 21:20 Kunda1 Tag Attached: MacOSX
2017-01-23 21:23 Kunda1 Note Added: 0007925
2017-01-23 21:23 Kunda1 Status new => feedback
2017-01-23 21:23 Kunda1 Tag Attached: #pending
2017-01-24 05:11 normandc Note Added: 0007946
2017-01-24 05:13 normandc Note Edited: 0007946 View Revisions
2017-01-24 10:23 wmayer Note Added: 0007949
2017-01-24 10:23 wmayer Status feedback => closed
2017-01-24 10:23 wmayer Assigned To => wmayer
2017-01-24 10:23 wmayer Resolution open => fixed
2017-01-24 10:23 wmayer Fixed in Version => 0.17
2017-01-24 12:29 Kunda1 Tag Detached: #pending
2017-01-24 12:29 Kunda1 Tag Detached: MacOSX