View Issue Details

IDProjectCategoryView StatusLast Update
0002104DraftBugpublic2015-12-15 13:15
ReporterbejantAssigned Toyorik 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.15 
Target VersionFixed in Version0.16 
Summary0002104: Draft WB Grid Shifts To Center Of Mass When Fixed To Plane
DescriptionThe Draft WB grid shifts to center of mass not only when set to Auto but when fixed to a plane.

This ticket was filed per Yorik's request.
Steps To ReproduceThe discussion is here:
http://forum.freecadweb.org/viewtopic.php?f=3&t=10899#p87995
and a file is in the post just before that one.
TagsNo tags attached.

Activities

yorik

2015-05-16 03:10

administrator   ~0006142

Thanks bejant!

TomGoBravo

2015-05-26 08:43

reporter   ~0006161

I looked into this a little deeper. When the object is selected alignToFace in WorkingPlane.py calls
self.alignToPointAndAxis(shape.Faces[0].CenterOfMass, shape.Faces[0].normalAt(0,0), offset)
which centers the working plane on the object. That makes sense. The problem is in DraftTrackers.py where gridTracker then uses the plane position to draw the grid without snapping the position. Changing this fixes the display of the grid, I haven't found the similar code for grid snapping (instead of display).

Issue History

Date Modified Username Field Change
2015-05-15 14:40 bejant New Issue
2015-05-16 03:10 yorik Assigned To => yorik
2015-05-16 03:10 yorik Status new => assigned
2015-05-16 03:10 yorik Note Added: 0006142
2015-05-26 08:43 TomGoBravo Note Added: 0006161
2015-12-04 01:00 yorik Changeset attached => FreeCAD Master master fd191b80
2015-12-04 01:00 yorik Status assigned => closed
2015-12-04 01:00 yorik Resolution open => fixed
2015-12-15 13:15 yorik Fixed in Version => 0.16