View Issue Details

IDProjectCategoryView StatusLast Update
0002103ArchBugpublic2018-02-11 22:41
ReportersilvesterdeAssigned To 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Platformx86OSWindowsOS Version7
Product Version0.15 
Target Version0.17Fixed in Version0.17 
Summary0002103: Arch: Dimensions jumping by 10e3 on german localization
DescriptionEntered standard-values for width and height in the arch-settings are multiplied by 10e3 for defaults and again when drawing.
Steps To ReproduceEnter value width in Menu Edit -> Settings -> Arch -> Standardvalues: 200,00 mm
Save and close.
See them change when choosing e.g. icon "wall": width: 200 m.
Start drawing, see the value change to 200 km
Draw a wall, measure it with the ruler: width is 200 km
Additional InformationThis happens on german systems with separators points for thousands and comma for decimals, where 2000 mm is equal to 2.000,00 mm.
Changing the language or localization is no option. Not only because of being a workaround and no solution, but most CAD-users are using other localized software-programs - and are localized in their communication.
Tagsduplicate, locale

Relationships

related to 0002195 closedeivindkvedalen Expressions Input validator doesn't allow comma as decimal separator inside input fields a second time 

Activities

yorik

2015-05-14 20:14

administrator   ~0006136

http://forum.freecadweb.org/viewtopic.php?f=3&t=10823

Kunda1

2017-02-02 03:34

manager   ~0008166

per @wmayer in https://forum.freecadweb.org/viewtopic.php?f=3&t=10823&start=10#p88282
> The problem is not the input field. The problem is in ArchWall.py. The passed text is in C locale and the input field class removes group separators for internal purposes. To fix this the passed text must be conform to the OS locale settings. You can do this with QLocale.toString.

wmayer

2018-02-11 22:40

administrator   ~0010942

See also:
https://forum.freecadweb.org/viewtopic.php?t=14630
https://forum.freecadweb.org/viewtopic.php?t=13581
https://forum.freecadweb.org/viewtopic.php?t=15758

wmayer

2018-02-11 22:41

administrator   ~0010943

The problem is fixed now in 0.17

Issue History

Date Modified Username Field Change
2015-05-14 17:31 silvesterde New Issue
2015-05-14 20:14 yorik Note Added: 0006136
2017-01-17 06:03 Kunda1 Tag Attached: locale
2017-01-17 06:03 Kunda1 Tag Attached: duplicate
2017-02-02 03:34 Kunda1 Note Added: 0008166
2017-02-02 03:35 Kunda1 Status new => confirmed
2017-02-15 08:38 kkremitzki Target Version => 0.17
2017-02-15 12:22 Kunda1 Relationship added related to 0002195
2018-02-11 22:40 wmayer Note Added: 0010942
2018-02-11 22:41 wmayer Status confirmed => closed
2018-02-11 22:41 wmayer Resolution open => fixed
2018-02-11 22:41 wmayer Fixed in Version => 0.17
2018-02-11 22:41 wmayer Note Added: 0010943