View Issue Details

IDProjectCategoryView StatusLast Update
0002072PartDesignBugpublic2017-05-06 19:04
ReporterppemawmAssigned Tokkremitzki 
PrioritynormalSeveritymajorReproducibilityrandom
Status closedResolutionfixed 
PlatformToshiba I7 LaptopOSWindows OS Version8.1
Product Version0.15 
Target VersionFixed in Version0.17 
Summary0002072: Polar pattern of slot pocketed from curved faces fails for certain number of occurrences
DescriptionThe objective is to create multiple slot features on a body of revolution that includes at least one curved surface. The slot sketch pockets as expected without any apparent error. When trying to use polar pattern to generate several slots (six in the example case) the function succeeds for some numbers of slots but fails for others. Please see attached file of examples.

The polar pattern succeeds for any number < 24 in the attached example if the cut faces are purely radial or conical but fails if one or both surfaces are curved.

The problem appears to be random in that the polar pattern succeeds and sometimes it does not. Recompute will sometimes succeed.

The problem has been reproduced by other users in the Help Forum.
http://forum.freecadweb.org/viewtopic.php?f=3&t=10707

Various configurations of slots and or holes were tried but none work for all occurrences every time.
Steps To Reproduce0. Revolve sketch that has at least one curved face and one planar face.
1. Mount sketch on planar face
2. Sketch slot and constrain
3. Pocket slot/through all
4. Select Polar Pattern/pocket/normal sketch axis/360 deg angle/6 occurrences
5. Error: transformed shapes do not intersect support
6. Check Geometry with Run BOP Check 'true' shows 0 invalid shapes
Additional InformationOS: Windows 8.1
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.15.4671 (Git)
Branch: releases/FreeCAD-0-15
Hash: 244b3aef360841646cbfe80a1b225c8b39c8380c
Python version: 2.7.8
Qt version: 4.8.6
Coin version: 4.0.0a
OCC version: 6.8.0.oce-0.17
TagsNo tags attached.

Relationships

duplicate of 0002028 closedkkremitzki Polar Pattern feature leaves faces missing 
has duplicate 0002246 closedkkremitzki Polar pattern of overlapping pocket feature produces several solids (negatives of the pocket) 
related to 0002248 closedkkremitzki Overlaps in polar patterns shouldn't always be errors 

Activities

ppemawm

2015-04-27 19:01

reporter  

slot_polar_pattern_FAIL.FCStd (332,373 bytes)

severoraz

2015-09-10 06:43

reporter   ~0006378

This bug seems to be a duplicate, or at least very closely related with bug #2028.

Issue History

Date Modified Username Field Change
2015-04-27 19:01 ppemawm New Issue
2015-04-27 19:01 ppemawm File Added: slot_polar_pattern_FAIL.FCStd
2015-09-10 06:43 severoraz Note Added: 0006378
2017-01-12 14:15 Kunda1 Relationship added related to 0002028
2017-01-13 22:32 Kunda1 Relationship replaced duplicate of 0002028
2017-01-14 13:39 Kunda1 Relationship added has duplicate 0002246
2017-03-22 01:07 kkremitzki Assigned To => kkremitzki
2017-03-22 01:07 kkremitzki Status new => closed
2017-03-22 01:07 kkremitzki Resolution open => fixed
2017-03-22 01:07 kkremitzki Fixed in Version => 0.17
2017-05-06 19:04 Kunda1 Relationship added related to 0002248